Trying to send corrections via 3DR radios

I am trying to send base corrections using genuine 3DR 915mHZ radios with little luck. I have tried flashing with 1.2 and updating and with the latest (2.2.6) and both exhibit the same results. I cannot get the reach to send any traffic(LEDs do not flash on either radio unit). I can manually connect both radios to individual computers and send serial traffic between the two with no issues. I am using the cables that came with the reach unit and have tried swapping the tx/rx lines already (no change). My base is setup to send corrections via UART at 57600 and no other functions (position output and correction input) are both off (trying to confirm multiple items are not trying to use the serial port).

Any ideas?

1 Like

Have you double checked that you’ve inserted the connector into the correct port on the Reach?

If you have, check to ensure that the radio themselves are establishing a link between themselves. I believe they light up solid green when they’re actively locked to each other. Is this all in-door testing, or are you attempting this over a longer baseline?

If it isn’t something like that, could you take more screen shots of your rover configuration? And I know you’ve swapped the TX/RX pins but it might be best to double check them once again if they’re establishing a link between each other but failing to receive anything.

Thanks for the quick reply!

I am using the port that is on the same side as the USB port (tried the other one for giggles at one point as well :wink:

The radios do link (green light) and when connected to a computer via USB can transmit text to and fro

Testing has been indoor and outdoor (was not sure if a good fix was required before it would start sending corrections).

If properly configured would the base not send corrections even if a rover did not exist? My assumption is that it would thus I should be seeing indication of traffic (have confirmed the LEDs flash when traffic is being sent manually using a computer). At one point to remove variables I had one radio connected to the base and one to a laptop to see if anything was coming through…nothing was. Anecdotally I did get some garbled data upon boot when connected to the connector on the non-usb side of the board

I have tried the cables both ways. Green and blue were the ones I swapped.

Thanks again!

Could you please provide a picture of connection?

The base will only send information if it has valid sat data. Are you sure that it finished coordinate averaging? This will not work indoor.

I did confirm the coordinate averaging was done (and it worked as expected if I changed over to tcpsrv for corrections vs serial/UART) during one phase of the testing but it is good to know this is a requirement as much of the later testing was back indoors thus not valid.

I will take a picture when I get back to my equipment.


Well, if the two radios are linked and ReachView has the correct baud rates the only thing left really is your cabling. While testing on the PC you’re able to send data but I assume that you’re connecting using a USB cable to each of the radios?

Also, what are you using to power the Reach during your tests? If your Reach and Radios are drawing too much from a smaller power supply they may not function properly either.

Regardless of the connection between the radio and the Reach, the radios should lock to one and another and show a green indicator without data being sent. If this doesn’t happen I would assume the radios might not be powering properly, or at all during your tests.

When configuring your input and output, is it showing a valid connection to an external device in ReachView?


You are correct, PC testing was via USB.

Power is from a 13000mAh USB power bank that outputs up to 3A.

The radios do show a green link…just no activity/traffic.

I should have time today to do more testing. Will probably try new cables (oh how I hate those df13 connectors!!) to start with :slight_smile:

New cables fixed it!

Thanks all :slight_smile: