Emlid

Community Forum

Trying to find IP address of NAVIO2


#1

hi…
Torn out all my hair… now tearing up scalp…!
Tried Nmap which easily finds my laptop and desktop and displays " No targets were specified, so 0 hosts scanned." when searched for " navio" and " navio2"
Trying to link Mission Planner to the NAVIO2 but without IP address it’s not possible


(Tatiana Andreeva) #3

Hi @spezzific,

Have you specified your network settings in /boot/wpa_supplicant.conf file?


#4

hi Tatiana…

Thanks for the reply… I have edited the /boot/wpa_supplicant.conf file as directed in the setup.

network={
ssid=“yourssid”
psk=“yourpasskey”
key_mgmt=WPA-PSK
}

I am thinking maybe the navio2 cannot communicate with wifi and only with Ethernet…?
What do you think…?


(Marc Lebret) #5

Hello,

What Rpi model do you have?

At home, I check the IP of Navio (Rpi) in the router directory.

Marc


#6

hi Marc…

Thanks for the reply…
The NAVIO2 sits atop the RSPI3+ and I have the IP for that


(Sebastian) #7

Then you have the IP for the Navio. The Navio is just an addon to the RPi. Without the RPi, it does exactly nothing.


(Tatiana Andreeva) #8

@spezzific,

Do you have monitor that can be connected to RPi over HDMI? When RPi boots, it displays its IP address in the last few strings before the login prompt. It’s the easiest way to resolve IP.


#9

hi Sebastian…

Thanks for the reply. I am trying to link NAVIO2 to Mission Planner 1.36
There are so many variables COM port types and number
I cannot get past Initial setup. All settings appear correct in NAVIO2 and my laptop IP is set correctly
It then asks me if this a Linux board YES is this a Bebop2 NO is this a Disco NO
Then it disconnects me… AAARGH…!!!


(Sebastian) #10

You can not upload the firmware through Missionplanner, it is already included with the emlid RPi image.
You should start by reading
https://docs.emlid.com/navio2
and follow the setup steps.
That should clear most of the problems you are having right now.


#11

hi Sebastion…

I should have been more precise. I have been through all the setup procedure you mentioned.
I have the Rspi3/NAVIO2 IP yet I cannot connect it to Mission Planner


#12

hello again…
I am trying the wpa_passphrase to upgrade and test the WIFI
When I type in “sudo bash -c “wpa_passphrase SSID password” >> /boot/wpa_supplicant.conf”
It replies “bash: /boot/wpa_supplicant.conf: Permission denied”


#13

hi Marc…

I have the RSPi3+
I was trying to find the IP of NAVIO2 when I should have been searching for raspberrypi
So I have determined that yet still cannot handshake with Mission Planner


(Sebastian) #14

You say you followed the setup process as mentioned in the docs and still you try to upload a new firmware with Missionplanner, because “is this a linux board”, “is this a bebop” does only appear during firmware upload in Missionplanner.

Do you have access to the Navio2/Rpi via ssh? Or do you use a monitor and keyboard connected to the RPi?


#15

hi Sebastion… Just following the mission planner setup wizard.
Access to the Navio2/Rpi is HDMI connection to a monitor and USB keyboard


(Sebastian) #16

You should read docs.emlid.com again.
The Missionplanner setup wizard is not mentioned anywhere in the docs. It does not work with Navio2.


(Tatiana Andreeva) #17

Hi @spezzific,

Here’s the information of how you can change the wpa-supplicant.conf file with keyboard and monitor.

Please try it and let us know how it’ll work.

It’d be great if you post here photos of the process.


#18

hi Sebastion.This was taken from the forum…
" fabienmonnier
Jun '15
Hello,

I I understand well, you are asking which Ground Station software to use with NAvio systems, right ? If yes, you can use QGroundStation, Mission Planner, APM Planner 2.0 or even MavProxy. They all use the MavLink protocol to discuss with the Autopilot.
I recommend to go to web page for each products and select the one you prefer or is better fitting with your needs.
thx"

If You cannot use Mission Planner which Ground station do you recommend…?


(Sebastian) #19

I never said you can not use MissionPlanner.
You can not use Missionplanners SETUP WIZARD. You will have to setup each item in the mandatory hardware tab one after the other.
You should follow Tatjanas link and get the wifi connection working, because everything else depends on it.


(Tatiana Andreeva) #20

Hi @spezzific,

Have you managed to establish a Wi-Fi connection?


#21

hi Tatiana… Sorry I have not replied to your thoughtful and encouraging comments earlier.
I am not sure but I think my problem might have been the powering of the PI/Navio2. First I used the Emlid power cable attached to a aeroplane Lipo battery to power the Navio2. Then powered the Raspi3+ using the little white Apple iPhone transformer rated at 5volts 1Amp. Probably better, I could have used the iPad transformer (5.1volts 2.1Amps) All worked but Linux complained it was under-powered. (Also a Flash, top right screen which I found out later meant the same thing)
After buying and using the recommended Raspi3+ power connector (5.1volts 2.5Amps) I powered up the PI/Navio2 and opened Mission Planner on my laptop and BINGO…! it all fired up and updated itself. Moving the PI/Navio2 unit was reflected in the HUD and looked pretty neat. One other thing I found helpful was tweaking WIN10 to assign a permanent lease on assigning the IP address to my laptop so it remains the same and I do not have to keep updating it in the GCS IP “sudo nano /etc/default/arduplane”
So now with the GPS antenna attached I go outside and it will locate itself here in Brisbane Australia… huurray…!