Trouble Viewing HDMI Stream on Edge in QGroundControl


I’ve been trying to get the live streaming working on the Edge. I’m using a Yi Action Camera (US Edition) and this micro to micro HDMI cable (

The order of steps I follow is this:

  1. Turn on drone with camera connected, but not powered on.
  2. Connect with QGroundControl (the edge specific version) to the drone. Everything else works perfectly.
  3. Turn on the camera.
  4. Try to start the video stream.

Nothing happens when I click start stream, it’s as if I’m not clicking the button at all.

I’m running the 64 bit version of QGroundControl for Edge on a Windows 10 laptop. The only difference in the setup with my Edge is that I flashed the latest version of the Edge firmware through Etcher instead of updating it through QGroundControl.




The CheckList is fine with Gopro (mine is Hero3+Black) but no way to stream with a Firefly 8S following it.

Do have stream working with my Firefly:

Edge is powered on,

GCS is connected,

Video Stream is requested (Stream Button),

Firefly is powered,

Video stream is OK. (1080-30fps)



Unfortunately your revised steps didn’t work either. Any other ideas?



Is AV Output On?


AV output is on, and the camera is updated to the latest firmware. Still no luck. I’ve ordered a GoPro Hero 5 Black to see if there is any difference.

Hi Camilo,

Do you have any updates?

I’m currently out of town, so I haven’t been able to do any testing. I’ll test with the Hero 5 and update you guys next week.



1 Like

No luck with the GoPro Hero 5 Black. HDMI output is set to live, I followed the checklist exactly. Anyone have any ideas? I’m stumped.

Hi Camilo,

Have you tried to stream to Edge from PC using HDMI-micro HDMI cable?

Does the screen of Go Pro camera become black after streaming starts?

So, if I try to stream to the Edge by connecting my PC to the microHDMI in port, nothing happens. On my computer, it doesn’t even detect the device plugged into the HDMI port.

To recap:

  • Connecting the GoPro to an external screen works. The GoPro’s screen goes black, and a live feed out shows up on the monitor correctly.

  • Connecting my computer to an external screen works. The screen is detected and I can display whatever I want on it.

  • Connecting my Yi Action cam to an external screen works. A live feed shows up on the monitor.

  • GoPro to Edge doesn’t work. The GoPro’s screen stays on, like it’s not even connected to an external display.

  • Yi Action Cam to Edge doesn’t work.

  • Laptop to Edge doesn’t work.

What gives? Did I just get a dud?

@tatiana.andreeva, @mlebret Any more ideas? I’ve tried everything I can think of, kind of at my wits end here.

Hi Camilo,

Sorry for delayed response.

One more question: could you please make sure that the stream in QGC is enabled? A camera can be detected only after enabling stream start.

If it won’t help, may I ask you to ssh to Edge and use the command raspivid -cs 0? It should start the video for a few seconds. Please inform us if the QGC camera’s screen reacts to it or not.

Double-checked QGC, stream was enabled. I ran that SSH command you gave me, no change on the QGroundControl side, but I got this error in the terminal:

I’ve got no idea what this means.


Thanks for doing the tests!

Please email to with a link to this thread and we will arrange a replacement. Sorry about the issue!