Trouble using LemonRx PPM receiver to connect with Navio2

Hello!

-I’m trying to connect my Lemon RX receiver to my Navio2. here is my hardware setup:

The pins are titled bind, throttle, elevator, aileron…, AUX. We think it should be plugged into AUX, but we also tried throttle and neither worked. Which one is it supposed to be?
We are sure that we bound the RC receiver successfully. (to a spektrum DXe)

-These are the things we tried:

image

image

we also updated the RCIO firmware.

No matter what channel we try or what position the joysticks are in, the value that cat /sys/kernel/rcio/rcin/ch* returns is 0.

Also, the bars on mission planner for rc setup aren’t green.

Has anyone been able to get this specific rc receiver to work with the navio2? Are we doing anything wrong and is there anything else we should try?

Thanks!

Hi @lucasjonasch98,

Could you try connecting a servo directly to the receiver channel and check if sticks on the transmitter make servo to move?

Hello! I’m working with Lucas.

We have connecting 3 servos to the LemonRX. If we connect them to the ‘Ailerion’ and ‘Elevation’ and ‘Rudder’ channels, the servos move with the joystick. If we connect them to ‘Gear’ or ‘Throttle’, they do not move with the sticks but do receive signal (they move slightly immediately when plugged in).

UPDATE: We purchased a Lemon Rx 6Ch LM0028 receiver which apparently does not output ppm. We’re switching to the Lemon Rx 7Ch LM0039 receiver which should work

Hi @saakib.akbany,

Please keep us updated regarding your tests with a new receiver.