Trouble connecting to M2 with reachview

I am having a problem connecting to the m2 module. It has worked fine for a couple of months, but yesterday it has started to not connect.

Starting up the m2 the leds illuminate as expected, once it has booted and is broadcasting a hotspot I connect to that hotspot and open reachview. The app shows the m2 and associated ip address but after clicking on this the screen just remains grey and does not enter to the normal status screen.

I have tried multiple reboots and connecting with multiple devices, tablets phones and laptop.

Eventually I used the pc software to reinstall the firmware on the m2, this was successful. Upon reinstalling everything behaved as normal. -success!

Then power cycled the m2 and it went back to the same behaviour of not connecting successfully :frowning:

It is running the latest firmware, it is being powered with the correct voltage and current, I have tried different power sources eg usb etc and it doesn’t help.

The only thing that was unusual was I noticed the very first time that I had issues connecting that the m2 was very hot. - could this be a sign of an internal issue and a faulty board?


Hi @hairyape1,

May I ask you if it’d possible to connect to the Reach via browser? Just open any Internet browser on your device connected to the same network as Reach and type the Reach’s IP to the address bar.

Do I understand correctly that you’re working with the latest stable firmware version v2.22.5?

Having fought this issue for a few hours, I saw a suggestion online that recommended just turning on the reach unit and leaving in view of satellites for a few hours and trying again and guess what… it just worked as normal and has functioned as normal ever since :slight_smile:
Lesson learnt… I was probably being impatient!


Thanks for the follow-up! Good to know the unit works as expected :slight_smile:

1 Like