Trouble connecting Reach rs+ to workplace WIFI network

The wifi network at my workplace has an authentication that is limiting us from connecting our units to the internet.

The wifi security is WPA2 enterprise at our workplace which requires a username and password input.

When trying to connect to this network from “known networks” it only allows for a password input.

We have also tried connecting to a hidden network using the “WPA Enterprise” security. But this also does not work.

So is there a work around to get our units on the internet using this internet connection? Is it possible to connect to the units just using the USB port and then use our desktop which is connected to the internet?

Firmware image and ReachView version : Firmware v2.16.2, reachview up to date

Hi Ace,

I’ll start by declaring I’m no networking wizard, so not sure how much help I’ll be. The (only?) upside is that I take a simplistic view of these matters!

With that in mind, first I’d check to see if you can connect your RS+ to any other wifi network. Doing this should build your confidence that you can then tackle the next step, for which I have no answer.

Assuming you can connect to any other networks, have you considered just doing what you need to do with a hotspot from your SIM-card enabled mobile or tablet? For a while at work we had a wifi networking problem and had trouble connecting our Emlid hardware, however it was to do with the network configuration/firewall? As a stop gap measure we used mobile devices for ReachView updates etc.

Once we fixed the networking issue (with some help from IT gurus) we’ve been able to connect our Emlid hardware to that via wifi for ReachView updates etc.

I hope this is of some help.

Regards, Al.

1 Like

I think you could solve that problem by connecting via ssh (use Putty on Windows) and editing the wpa_supplicant file.

If you already use a linux computer you might simply copy the configuration lines.

Have you been able to connect to the device in any way, @acebulsk?

Hi Andrew,

Yes I can connect to the devices in a regular wifi environment (i.e. at home) but it would be nice to be able to do firmware updates at our workplace to avoid transporting our three units back and forth.

Do you think Tobias’ suggestion with Putty will work?


It’s a common problem with WPA Enterprise networks as they usually don’t provide access for 3rd-party devices. Usually, contacting IT support of your network helps to resolve it. We had such a case before and users were able to connect after visiting support with the device.

Our IT support wasn’t able to assist.

Any ideas for a workaround ?

Get new IT Support. : /

1 Like

If your totally locked out of the Enterprise network, then just use another network as mentioned that’s NON-enterprise? I.e your own mobile hotspot? Dial up modem? : /

If desperate, maybe a free wifi like Starbucks, McDonalds, Chuck E Cheese, etc. Some strip joints offer free wifi to, but may wonder why the hell your dragging that equipment in.

We solved the issue by connecting a wireless router to the Ethernet here at work and connecting the reach rs units to this.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.