Tracked Rover Problems


We are working on a programme to develop a small tracked Rover and are using a Navio2 and RPi2 running Ardupilot (V3.1.2) set up using mission planner.

We are experiencing difficulty with GPS fix in the early evening and the position moves regularly by a few tens of metres. This is more than we anticipated and is making testing problematic. The area is not built-up and we would expect to get an accurate and constant fix. We have adjusted the positions of the boards away from the small motors on the test vehicle but it doesn’t;t appear to make any difference.

The demand heading for the next waypoint does not always actually point toward a waypoint at all even when we have set only one and the vehicle is in auto mode. Consequently the vehicle often travels away from required track.

The PID controller within Ardupilot doesn’t behave as previous PIDs I have used and resists attempts to tune it. Regardless of the gain terms, we can’t get the vehicle into oscillation around the required track so that we can tune the D and I gains.

Do you have any ideas on what might be wrong?


Could you please post a picture of how the GPS antenna is installed on you rover?


We’ve tried the following positions - please see photos. We have tried separating the stack and antenna from the motors with foam to reduce EMC but it didn’t help at all.


I recommend to add a 100mm round metal disc below the antenna, it will serve as a ground plane and will improve reception.

Okay thanks, I’ll try that to see if the reception improves.

Do you have any ideas regarding the waypoint or PID problems?


This topic was automatically closed after 100 days. New replies are no longer allowed.