Tp link wn725n wifi adapter driver

Hello!
I’m trying to enable wifi on raspberry pi 2 using my TP LINK wn725n wifi adapter with no luck.
I can see adapter using lsusb:
Bus 001 Device 0006: Id 0bda:8179 Realtek Semiconductor Corp
or using dmesg.

I found rpi forum with precompiled drivers here: https://www.raspberrypi.org/forums/viewtopic.php?p=462982#p462982 and tried to use version for 3.18.9-v7+ #767, #768 - 8188eu-v7-20150307.tar.gz (https://dl.dropboxusercontent.com/u/80256631/8188eu-v7-20150307.tar.gz), it has precompiled ko module. I’ve changed kernel version name from 3.18.9-v7+ to 3.18.9-rt5-v7+ in install file to make it work. But when I’m trying to run ifconfig it shows only eth0 and lo interfaces.
Also I found driver sources on github: https://github.com/lwfinger/rtl8188eu

What am I doing wrong? Should I compile the sources on raspberry to make them working?

Hello,

Precompiled modules mostly won’t work on different version, so you have to compile the module yourself.
Here is the source code matching to our kernel:


You can use it to cross-compile a module on a computer to speed up the process.

In fact, I would recommend to obtain a WiFi adapter that is supported by RPi’s kernel by default. It would save your time because you won’t have to recompile the module when the system gets updated. Information about WiFi adapter compatibility can be found in the following table:

1 Like

Bought Asus N10 nano adapter - and it worked by itself, no config required!

Hi, have u manage to make this work?

Hello Michael,

Could you please explain how you made the Asus N10 nano adapter work and give your settings.

I’m struggling to make this same adapter work…

I have connected the adapter directly into the Pi (no powered USB hub).

I have configured wpa_supplicant.conf as follow:

and /etc/network/interfaces as follown:

When I run iwconfig, I can see that I’m attached to the wireless network:

Then, if I remove the Ethernet cable, I can putty the RPI from the computer… which means that WIFI link works…

but as soon as I restart the RPI, the WIFI link doesn’t work any more.

From the RPI, I can’t ping the computer anymore:


with 192.168.1.70 being the fixed IP address associated to the ethernet port.

I have also noted that I get some error message when I try to restart the network interface:

I have already updated the system with “sudo rpi-update” and “sudo apt-get update”.

The “iwlist wlan0 scan” does see the wifi networks around me.

Thanks a lot.

Hello. Could you help, please.

Trying to attached the TP-LINK TL-WN822N https://github.com/bortek/EZ-WifiBroadcast/wiki/Pictures as in the github EZ-wifibroadcast page. When connected to Navio2 there isn’t any power to the dongle. They’ve clearly used this type and I’ve seen mentioned the name and model, though I can’t see to track it down again. It was mentioned so I purchased two to try. It is difficult finding any of there here in Australia, so I went with this one. Am I suppose to supply an external power supply? (The costs just keep going up and up!) Any help is greatly appreciated. Thank you.