Tower Ground Station


When I have my FC connected to Mission Planner, I instantly receive all flight data (roll, pitch, yaw angles, velocity, gps location, battery monitor etc).

When connected to Tower on Android, however, I can’t seem to receive data from my Navio2. I am connected to it, but I can’t see its angles, gps position or anything.
When pressing “Parameters” on the left menu, I receive a loading notification “Refreshing Parameters” which never leaves 0%.

Would anyone know why that happens?
Thank you.

A few more details would have been helpful…

  1. Are you trying to connect with udp or tcp?
  2. Did you disconnect from Missionplanner?
  3. Same Wifi as with Missionplanner, Android hotspot or Navio/RPi hotspot?

1.I am using udp. Same as when I connect to mission planner.
2. I did disconnect from mission planner.
3. My navio2 is connected through Android Hotspot.

Did you setup the second telemetry option with the IP of your smartphone?

No, I had only set the first telemetry option with the IP of my phone. Should I set both? Or should I leave the first option as the IP of my PC ground station and the second one with my phone’s?

I just wanted to make sure you changed the setting to your phones IP. It does not matter which telemetry option you use. If you plan to frequently switch between PC and smartphone, it might be easier to use one telemetry option for each.
If you set everything right it should work just as it does with MissionPlanner.
Check the syntax again and/or try to set one option to tcp:, to use as a universal backup. This should work with smartphone and PC.

This is what I have right now:

#Default settings for ArduPilot for Linux.
#The file is sourced by systemd from arducopter.service

TELEM1="-A udp:"
TELEM2="-A udp:"

#Options to pass to ArduPilot

Where is the IP address of my PC and is the address of my Android Smartphone (Samsung galaxy s5).
When connected to Tower, this is my screen:

You can see I have no battery information, all angles are 0º and there is no display of the drone location.

When disconnected from my phone, I can’t connect to mission planner unless I comment the TELEM2 line. Connection with mission planner runs perfectly.

Would anyone know why?

If I set one of the telemetry options to tcp:, how do I set the options on mission planner and tower to connect through tcp?

Thank you!

My final goal here is to use Tower’s “Follow Me” option.

When only setting one telem option as tcp:, I was able to successfully connect to mission planner . When disconnected from mission planner and trying to connect to Tower, I get the following error message:

“Connection failed: failed to connect to / (port 6000) after 20000ms”

These are the same IP address and port I use when connecting to Mission Planner.

You can not use the -A option two times.
Use -C for telem 2. The different letters are Ardupilots reference to the hardware UARTs a microcontroller based flighcontrol would have. It is all explained in

Got it. Still, that doesnt explain why I don’t see flight information on Tower, even when I was enabling only one udp telemetry option.

Also, I have not been able to connect to mission planner or Tower through TCP This is what I have on my copter:

TELEM1="-A tcp:"

On tower or mission planner, I select the tcp option, push connect and provide my copter’s IP address (acquired through command hostname -I) and port number 6000.

I tried tower today with my rover. I got only limited telemetry in tower, while qgroundcontrol on the same device worked without a problem. I suspect there might be a bug in tower.

Today I tried QGroundControl… It doesn’t display my drone’s information either:

I’m connected through udp.

Would anyone have an idea on how to solve this? My Navio2 displays a Green LED, which means it has a 3D gps lock. Also, I can see it on Mission Planner’s map.

Also, does QGroundControl support a “follow me” option as well?


“Vehicle 1 did not respond to request for parameters. This will cause QGroundControl to be unable to display its full user interface”

Is there anything I should change in order for my copter to respond the parameters request?


This topic was automatically closed after 100 days. New replies are no longer allowed.