Throttle jerks and studders as i turn the steering

BTW: everything works using a pixhawk with ardupilot stack configured as a rover.

i re-imaged the sd card and started from the beginning because the navio would not cummunicate with the traxxas esc. now the throttle does communicate with the esc nice and smooth. however when i turn the steering using the remote- the wheels turn but the its making the throttle jerky without me touching the throttle on the remote.

so now my problem is the throttle motor jerks and st-udders as i turn the steering on the remote.

i would appreciate any assistance and thank you in advance.

Hi @j98221,

Any chance you can share the video of such behavior?

its resolved. what solved it is by applying an external 6v directly to the rails. what i had done earlie was to connect the positive wire from the esc to the rails thinking the esc can supply enough current. but i was wrong. the external 6v to the rails solved the problem.


Thanks for sharing the solution!