Three problems: no firmware update, wrong wifi network, and little beep noise

Hello, I just got three Reach RS+ and doing settings for the first time use.
I successfully completed the setup for two of them with the quick start guide video but the other one is not functioning as the previous ones. All of the problems here is for the device not functioning properly.

It had the first problem during updating the ReachView firmware. The firmware won’t be updated so I just rebooted the Reach RS+ device. From that time, ReachView just passed the first screen for update and led me into the app main screen with several menus. I checked the firmware version and it was 2.11.1. For the other two, the firmware versions were all 2.11.3. So I kept tring to update the firmware in the settings menu. Interestingly, the firmware check indicated that it was up to date and still won’t to be updated.

The second problem is when I changed to the wifi network of the Reach device to my school network, ReachView did not ask password. Guess what? The school network requires ID and password but the Reach device was already attended to the network without id and password. Now, the network LED of Reach is blinking. So I accessed the network with my ipad but nothing was on the list of the Reach Units screen of ReachView. Now, I have no idea what I should do get it back to the original network.

Lastly, only this Reach RS+ device emits a very little strange beep noise from the very first time I first powered on. Of course, the other two devices are very quiet. I wonder if the very little noise is normal.

It sounds like the unit was stuck during the update and you rebooted it. If it was stuck because of perhaps a network or download failure, there isn’t much else to to do. The consequence of that is only some of the update is installed, but not all.

The best thing to do now is to reflash that unit to get it back into a normal state:
https://docs.emlid.com/reachrs/common/reachview/firmware-reflashing/

I can’t comment on the quiet noise you hear, but perhaps it is a PWM circuit for the charger or something like that.

1 Like

Thank you.
Yes. I got the solution and reflashed the device.
The problems were solved except the little noise.

However, I am struggling with another problem.
Reach won’t to get into a new wifi network.
At the very first step for setup, the reachview app asks a new wifi network information.
I inserted the correct network name and password but it won’t get into the network.
I’ll try that again tomorrow.
Thanks.

1 Like

Is the network on your smartphone or mobile device hotspot, or is it a Wi-Fi router, etc.?

What is the name of the network? (any strange characters, etc?)

Is the encryption type is set correctly?

Hi Kon Joon,

Do you have any updates? Have you solved the issue with Reach connecting to a new Wi-Fi network?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.