The RMS is extremely high. How can i fix that?

Before creating a new thread please refer to Quickstart guides for Reach and Reach RS.

In case you are creating a thread about an issue it is necessary to provide following information to get help:

  1. Firmware image and ReachView version.

  2. System report.

Simple system report
app version: 28.4-r0
current_network:
  ip: 192.168.0.110
  security: wpa-psk
  ssid: TP-Link_1126
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 126
    mode: single-and-hold
  output:
    io_type: 'off'
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 18.23
        frequency: 903500
        output_power: 20
      ntripcaster:
        mount_point: REACH
        password: '***'
        port: 2101
        username: reach
      ntripsvr:
        address: caster.emlid.com
        mount_point: MP4517
        password: '***'
        port: 2101
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1004:
      enabled: false
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1008:
      enabled: false
      frequency: 0.1
    message_1012:
      enabled: false
      frequency: 1
    message_1033:
      enabled: false
      frequency: 0.1
    message_1074:
      enabled: true
      frequency: 1
    message_1084:
      enabled: true
      frequency: 1
    message_1094:
      enabled: true
      frequency: 1
    message_1124:
      enabled: true
      frequency: 1
    message_1230:
      enabled: false
      frequency: 0.1
bluetooth:
  enabled: false
  pairing:
    discoverable: false
    no_input_no_output: false
    pin: '***'
correction_input:
  base_corrections:
    io_type: lora
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 18.23
        frequency: 903500
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
        send_position_to_base: true
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: false
    raw:
      autostart: false
      format: RINEX
      rinex_options:
        logging_interval: 30
        marker_name: Centro
        pole_height: 1.14
        preset: custom
        satellite_systems:
          beidou: false
          galileo: true
          glonass: true
          gps: true
          qzss: false
          sbas: false
        time_adjustments_enabled: false
      started: false
      version: '2.11'
    solution:
      autostart: false
      format: LLH
      started: false
  settings:
    debug: false
    interval: 24
    overwrite: true
    simultaneous_logging: false
network:
  tcp_over_modem: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: tcpsvr
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: false
    update_rate: 1
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35
sound:
  mute: false
  volume: 100
  1. Detailed problem description. How does observed behavior differ from the expected one?

When I open up RTKplot with the .pos file and look at the statistics at the top right corner, the RMS shows at 334,118 meters. I processed this result in static mode with a base station that was several kilometers away so the only explanation I can think of is that RTKplot is using also using the base coordinates to calculate the RMS, but I’m not sure. If it is what I think, how can I take those coordinates out of the equation? so that I have an accurate way of assessing the precision of my results.

Also, I don’t know if I moved something I shouldn’t have in the settings, but every time I open the pos file it is showed really zoomed out. Like this:


It’s not a big problem, but I would prefer it if it were already zoomed into the points like the first photo? Are there some settings I could use to always open the file that way?

Lastly, I would appreciate it if you could tell me about the different options I have to assess the precision of static measurements derived from emlid studio or RTKlib.

  1. Your step by step actions.
  2. Picture of the setup and connection scheme.
  3. If you are reporting an issue with solution, please provide RTKPLOT of observations from rover and base (with all the systems enabled and LLI flag for cycle slips). Instructions can be found here.
  4. Attach RINEX log files for rover and base. If you prefer to keep them confidential, you can email the files to support@emlid.com with a link to the thread. Please note, that in this case, other community members will not be able to help you.

Can you try the same in Emlid Studio?

Thanks for your answer. Can Emlid Studio calculate the RMS? If so, how can I turn it on or where is it shown?

Yes, Emlid Studio is based on RTKlib, just in Emlid flavor.

Sorry, what do you mean by Emlid Flavor?
You expect the problem of the RMS value to be corrected if I open the same result with ES? how can i do that? When I drag and drop the pos file in Emlid Studio, the RMS value is not shown anywhere on the screen.

Hi @edgarfer03,

We’ve added many improvements in Emlid Studio. If you process the logs there, the result can differ from the RTKLib’s one. I assume that’s what Christian meant.

You can find the standard deviations in the .pos file. If you notice anything unusual with them, please share the logs for a check here or via support@emlid.com.

2 Likes

Thank you @kseniia.suzdaltseva, I did post process the logs with Emlid Studio, and I don’t see a problem with the .pos file. Most points are fixed and standard deviation looks fine. It is just the RMS value that seems unusually large. But unless I’m mistaken, the RMS does not show on the pos file. So it must me a mistake anywhere else on the software configuration, I suppose within RTKplot. I just don’t know how to fix it.

Hi @edgarfer03,

You are right – there are only standard deviations in the .pos file. They’re enough for the accuracy estimation of the dataset, though. To explain how it works, I need to touch on how the RMS and STD values differ:

  • STD can help you with the accuracy estimation calculated from 1 set of points. Basically, it measures the dispersion relatively to the mean of the same dataset.

  • RMS comes in handy if you want to compare your dataset to other values, for instance, a known point. If you change the point for the comparison, RMS will change as well. And if you choose the dataset’s mean as the known point, RMS will be equal to STD. So, if you’re aiming to estimate the accuracy of 1 dataset, it’s enough to have only STD values.

The statistics you see on the main RTKPlot screen can be recalculated depending on the Coordinate Origin (you can set it in the RTKPlot settings) and the Solution type. It’s a tricky thing, which can create a room for error. That’s why I’d recommend checking standard deviations in a .pos file from Emlid Studio as a more reliable way to evaluate your results.

2 Likes