The new Reach RS2+ with LTE

Hi Olga, Is there any path to get the previous RS2 updated with the new LTE Modem?

Currently just using an cell phone or portable hotspot for the cell/internet connection which works fine and serves multiple connections if needed. Though sometimes it would be handy to have the cell connection directly at the receiver when going back country.
Thanks, Mark


Hi Olga,
Is there a buy back program for Reach RS2? We recently purchased an RS2 but have not been happy with the performance as many of the 3G towers have been phased out.

Hi Mark,

Adding LTE support isn’t only about changing the cellular modem. It also requires reworking the board and firmware. That’s why we released the new product with LTE support.

I agree that having the cell connection makes things easier. But Reach RS2 needs 2G or 3G coverage. Another way, as you said, is working via mobile hotspot.


Hi Andrew,

but have not been happy with the performance

Is this related to 3G shutdown only, or are there some other difficulties you faced?

Currently, we don’t have such a program. Reach RS2 still can be used with 2G or with a mobile hotspot. Is there 2G coverage on your worksite?


We are experiencing issues with connecting via sim card on RS2.

Is this eliminated in RS2+?
What else are differences and gains in the receiver upgrade?
What advantage do I have in switching from RS2 to RS2+?

Hi Mauricio,

I remember you reported this SIM card issue. It was this thread, right?

I can hardly say if this eliminated in Reach RS2+, as we didn’t finish the troubleshooting. Would you mind investigating it further? Most likely, we’ll be able to solve it for Reach RS2 as well.

I’d say RS2+ is made to work in even more severe conditions than RS2 handles. This is what we mean when say “body design improvements”. For example, Reach RS2 can deal with heavy rain, but RS2+ sealed even better so that not a single drop leaked through the plugs.

And of course, with LTE, you can go to a more far away place. But there is no catch: Reach RS2 may still work fine for you. Decide depending on your own needs!


The problem with the SIM card continues.
I couldn’t solve it.

If I connect the RS2 to the Wifi it is wonderful.
If I connect with the SIM card it keeps connecting and falling.

It’s a little disappointing as we only just purchased the RS2 the other week, and were not informed about the new version. We almost didn’t buy the RS2 because of the lack of 4G support. And now I see the RS2 has been discounted…

1 Like

Bueno, acabamos de adquirir el rs2 hace dos semanas. No nos han avisado de ninguna parte. Es decepcionante tener un equipo con obsolecencia programada sin avisar. Gracias Emlid


I’m ready to troubleshoot it further. But can we move this discussion to the thread I shared above? Just to not mix things up.

I’d really like to check the Full system report. It should tell what exactly Reach misses in your SIM card settings.

1 Like

Hi @Brocxen, @javipined,

We recently released BLE support for field-ready devices, including Reach RS2. There is also NTRIP-over-BLE option.

It uses the Internet connection of your mobile phone to connect Reach to NTRIP. So, if you have a 4G/5G SIM card in your mobile phone, you can work with Reach RS2 in remote areas as well as Reach RS2+.

Reach RS2 is still fully supported product. We continue to release firmware updates and provide technical support for that. Also, we add such features as BLE to make your workflow easier.


Perfecto!!! Gracias por la respuesta.
Siendo así, veo que poneis medios para solventar problemas.
Un saludo.

Hello. half a year ago I reported a problem with GSM communication in RS2, the fault is the poor quality modem that is installed in this device. As usual, the problem was not solved, the introduction of the RS2 + model only convinced me that it was so. The RS2 isn’t worth a cent. you can kick me out of the forum for writing the truth about this equipment, but I will advise anyone not to buy the Emlida RS2.

Hi @geodezja-skwierzyna,

The reach RS2+ release doesn’t mean we’re not going to work on your issue and any other issues, which may appear on Reach RS2. But as I said before, not all issues can be solved fast.

BLE can be a workaround for your case as well. If you face any difficulties with the BLE, we’re ready to sort it out.


¡Gracias por tus comentarios!

BLE works only with your ReachView software. I work on the surpad there is no ble and the bluetooth connection does not work when GSM is in the controller I can not skip this problem because I am trying to do it since I have an emlida or 1.5 years.

Love the LTE modem!

Not too impressed with the materials.

Didn’t shut the USB flap tightly, and nearly tore it off putting back in the case for the second time ever.

Then looked carefully, and the plastic for each door is cracked already. I literally never even opened the LORA or EXT flaps!!!

1 Like

Same thing happened to our RS2’s so I’m being very gentle with the 2+.


I agree. This is one of the hardware flaws that need to be addressed

1 Like

I went through your Bluetooth case again and took the last Full system report you shared with us. In the Bluetooth log, I indeed see some connections and disconnections. But this report was shared in 2G troubleshooting case. So, I can’t be 100% sure these disconnections are related to the Surpad.

Another thing is that this report is from 28.1 firmware version. But in 28.2, we made some changes regarding Bluetooth. So, any conclusions I draw based on this report become irrelevant.

Also, you recorded the screencast, and the interface of your data collector looks similar to Android. If so, we must check connection with the Lefebure app. Android OS differs a lot from manufacturer to manufacturer. Also, if the connection is made via a 3rd-party app, we lose the track. We know Reach sends data, but we can’t follow what happens on the Surpad side. That’s why we need to check the Lefebure because it’s well-tested and we understand how it works.

If we could gather all the data we need in one place, we would find a reason for your issues with Surpad. In 28.2 version I mentioned, we fixed some issues with Bluetooth, because we confirmed them during one of the troubleshooting.

Please, update your device to the latest firmware version, test it with a Lefebure app, and share the Full system report. I’m highly interested in resolving your issue.