The maddening adventures of the RS+ initial setup

Ohhh the fun! I purchased two Reach RS+ units in effort to utilize one as a base and one as a rover (connected to my ROV boat). The Emlid system came as a suggestion from the boat manufacturer. I ordered the units along with the boat back in June. The RS+ units were on back order so I have been using the boat GPS which is sketchy. My RS+ units arrived on October 9th. I excitedly set them up following to a tee the video tutorial. Fail. I attempted three more times, fail, fail, fail. This morning I involved one of our IT peeps who flashed both units. Ahhh fresh start. This should work…FAIL. ver the course of the last week I have perused the forums and have seen this exact topic but it appears that the strings are full of “try this” answers but nothing has seemed to work.

I am able to connect to both units via WIFI from my cell phone. After connecting to a unit my only option is “Manage Router”

After I choose the option I am able to add a WiFi name and password. In this case I used my Verizon Hot Spot

The unit connects to the WiFi and states that I need to connect my WiFi to the same network.

I then connect to same network.

I open the Reach View App

And…BAM! nothing…

I have restarted both units and the app multiple times. I have honestly never had this much trouble with a brand new purchase of any kind. Any help would be, well, helpful.

Hi @migrainz,

Have you tried to open ReachView app over web browser using Reach IP? You can resolve Reach IP address using any network scanning tool.

Hello Tatiana. I downloaded Fing and gave it a shot It doesn’t appear as if anything changed. When I connect to the Reach RS+ network using the WiFi on my cell phone I am able to see it on the Reachview app. When I click and open the Reach RS+ on the Reachview app it brings up the test screen (all tests passed) and then the WiFi screen. I connect the Reach RS+ to my hot spot, disconnect my phone from the Reach RS+, and connect my phone to the same hotspot. I open the Reachview app to a black screen. After approximately 15-20 seconds I receive this error in the ReachView app:


When I tap “RELOAD”…nothing.

In my experience it’s not going to work in a mobile hotspot. If you try a home WiFi network you may need to troubleshoot firewall issues. Normally a direct wifi connection from mobile or PC to the receiver’s hotspot works flawlessly. Many mobile devices need to be told to reconnect automatically to the receiver hotspot because it doesn’t provide internet.
What specifically happens when you attempt your phone to the receiver’s hotspot? Manage router?

Thank you for the response Michael. I can connect to the RS+ with my cell just fine. When I connect to the RS+ I am able to choose the “Manage Router” option which appears to connect to the ReachView via web address through Chrome.

When I do so the app runs “Tests” popping up a green checkmark. The app then opens the “WiFi” menu. That is where it stops.

The hot spot may be the problem! Thank you for your insight. I will connect to my home network this evening and see if I can resolve the issue.

Hats off Michael. You NAILED IT! I have worked on this set for several days and little did I know the solution all along was the hot spot.

I simply ran setup on my home network and kaboom. They WORK!! Thanks again my man!


Looking forward to some great projects !


Happy shooting!

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.