The changes couldn't be applied to Lora (Lor101)

Hello,

  1. Firmware version 28.1, ReachView version 6.12.2

  2. Simple System Report

  3. Problem


    The problem is that we can’t apply changes to the Lora (Lor101). That is why it stays only serial mode.

  4. We tested that if Lora receive the data with using oscillator, we observed that it receives, so there is no problem in connection.
    However updating the software to the last version, changing different frequencies were tested but nothing has solved the issue.

1 Like

Hi @faridguliyev,

What exact LoRa settings are you trying to set?

I see from the report that you chose all constellations. I just want to note that only 9.11 and 18.23 air data rate options are available with this selection.

Also, please make sure that LoRa frequency matches your country’s restrictions. They are different for each country, but they are listed right after LoRa settings:

Have you successfully used LoRa before?

1 Like

Thanks for the quick response. Yes, it is my first experience using Lora. I have tried also constellations which was showed at base-rover tutorial, but nothing has changed, and there is no frequency restriction in our country. I reset all parameters to default version, and do all steps again as tutorial showed, but nothing has changed too.
I think that, the problem can be in device, becuse we have ordered the Reach M+ UAV Mapping Kit, but instead of M+ the M2 was in packet. I know that M2 is multi-band, however RS+ is single-band. Can problem be in there? Is RS+ is combatible with M2? or single-band is compatible with multi-band? If it is not combatible, then I think only solution is to returning the order.

Please email us at support@emlid.com with your order number. We’ll solve this situation with the mixed up modules.

Reach RS+ can’t be a base for Reach M2. Still, it shouldn’t affect LoRa performance. So there is some other reason. At this stage, I also need the Full system report from your device. It contains sensitive information, so this question is better to address via email too.

2 Likes

Thanks for the solution and consideration. I think that is it. The problem was in compatibility between RS+ and M2. The thing is in Lora performance is that, if we take RS+ as base, and M2 as rover, we can apply lora changes to base (RS+), but can’t apply to rover (M2). However if I take M2 as base, and RS+ as rover, i can apply lora changes to base (M2), but can’t apply to rover (RS+). I think that can be only because of compatibility. I will try to send you the Full system report, if problem continues. Thanks again.

Sorry for the late response Mrs. Svetlan, because of the weekend. We ordered M+ already, but I think as you said, if there is a problem about Lora performance,it shouldn’t be because of the compatibility of rs+ and m2. I did all steps again as rs+ base and m2 rover, still there is a problem. That is why i am going to share you both base and rover full report along with screenshots.
Base device (RS+):
There is no error in Base, all is good.

Rover device (M2):
The problem is in rover device, I can’t apply the changes (I choose Lora and it gives and error and be defualt input (Serial)).

Hi @faridguliyev,

First of all, I’ve removed the reports from your post as they contain sensitive info.

But I’ve downloaded and checked them. There are error messages about LoRa in the report. But I’m confused with one thing. You mentioned there are no issues if you configure Reach M2 as a base. Can you confirm this? I’m asking because I can’t find this in the logs.

Also, you’ve mentioned in another thread that LEDs on LoRa don’t blink. Can you share the photo or video?

2 Likes

And also, Farid, please PM me with your order number. We don’t want you to purchase Reach M+ on your own if you received Reach M2 by mistake. It’s essential for us to investigate what happened.

2 Likes

Okay, thanks for removing it because of sensitive info, and sorry, that was my mistake about m2 as base. I can’t apply changes to M2 at both cases (as base or rover).
About order, I want to say that I can’t share order because we have ordered it with another company, that is why i don’t have order number. But we have already returned it (that is why I can’t share photos/radio too), and the M+ will be here after 1 week. I will update you after I receive M+, but still i don’t know the lora issue will resolve or not.

Hi Farid,

I got you. I’ll be waiting for the news!

I got exactly the same problem since last year. I tried also all the combination of constellation. I also tried using only gps/glonass. However, the same result. I cannot apply changes to the lora. I ended up using ebyte Lora now.

It os not about compatibility. Since 2018, iwas using m+. Then, last year it started the problem in lora. I cannot configured it. It keep saying changes couldnt be applied. After being tired of asking for support, i resolve it using an ebyte Lora. Atleast i can do tje surveying now.

Hi Yasser,

I couldn’t find your support ticket, but it seems we didn’t get the investigation to the end. There are no known issues with applying LoRa settings.

Usually, this error message appears if you choose GNSS settings that overload LoRa radio. But even this scenario is possible in Reach Panel only. ReachView 3 just won’t let you select inappropriate settings.

So, I’d ask you to contact us at support@emlid.com to find out what’s wrong with your LoRa.

Hi Svetlana,

After we received Reach M+, we checked all steps again. The problem was gone, and everything is working properly. It seems the problem was on Reach M2.

Thanks a lot for helping us.

Regards,
Farid

Hi Farid,

Thanks for the update! If you need any other help, you’re always welcome.