TFMini on Uart

I am having issues getting my TFMini to connect via UART on my Navio2 board. I saw on another post (which is already closed) that the last guy had the same issue as me. He said the following resolved it:

TELEM3 to UART port and now it works.

However, I can’t seem to find in mission planner where to set this. Can anyone offer any insight?

Hi Tommy,

May I ask you if you’ve checked the pinout scheme of Navio2 to make sure you connected the right ports?

Have you had an opportunity to look up this guide in ArduPilot’s docs on how to connect TFMini to the flight controller?

Hi Polina,
Yes, I have checked the pinout scheme of Navio2 and confirmed. I am sure it is working in Linux, because I can connect to /dev/ttyAMA0 and see data coming through for the TFMini.

Yes, I did follow the directions on the link you provided and the TFmini is configures using the same settings on that page.

I wasn’t sure if SERIAL4 maps to the linux ttyAMA0 device?

For anyone else having this problem with the TFMini, I had to edit:

sudo nano /etc/default/arducopter

Then I added the following two lines:

TELEM3="-C /dev/ttyAMA0"

Options to pass to ArduPilot

ARDUPILOT_OPTS="$TELEM1 $TELEM2 $TELEM3"

After a reboot, the TFMini appears to be working now.

2 Likes

Hey Tommy,

Glad you solved the issue!:blush: