Telemetry radio activation on Navio 2

When setting the telemetry to USB adapter ( /dev/ttyUSB0 ) do I have to delete the # in front off the line to get it working?
and are there any other changes wich should be applied to the telemetry adjustments?

Thanks for your replies


As mentioned in our docs, all lines with # have no effect.
Thus yes, you need to delete the # to pass TELEM2 option to ArduPilot.

Do I have to add an # at the line specifying the Telem1 line?

I assume your telemetry options look like this:

TELEM1="-A udp:"
TELEM2="-C /dev/ttyUSB0"

With this configuration ardupilot will send telemetry over both UDP and USB radio.
Commenting one of the lines will prevent telemetry sending.

Ok. Thanks

bumping this as I cant get my OSD and 3DR radio working concurrently on the Navio2…only one or the other works, not both…I use serial port for radio and usb-ttl adapter for the OSD…they both work, just not at the same time ever

TELEM1="-A tcp:"
TELEM2="-C /dev/ttyUSB0"
TELEM3="-C /dev/ttyAMA0"

Options to pass to ArduPilot


You can not use two -C options. The different letters represent the different serial ports a MCU autopilot like the pixhawk would have. So telling Arducopter to use two hardware devices for one serial output does not work.
You can use option -D, but you have to set the serial2 parameters right with Missionplanner.

This topic was automatically closed after 100 days. New replies are no longer allowed.