Telemetry - Air and Ground not pairing

Hi everyone,

I am almost done on my first quad copter build but I have trouble with the telemetry module has it has never wanted to communicate between air and ground… Air is blinking red and green. Ground is blinking red.

I managed to load once the ground parameters from ardupilot Sik Radio menu but not after.

This is a 433Mhz 500mW.
I am looking for another one as I red on several topics that this model is veeeery old.

What would be your model advice for a robust telemetry connection for navio 2 ?

I managed to get drivers for windows, but no change.
I also tried to modify the arducopter file, nothing changes either.
I also tried to change the baud rate to 57 and no changes…

Below are details of my steup:

Hi @Flyghost,

Usually, there is no need to configure telemetry radios additionally. It should be enough to specify the right option in /etc/default/arducopter.

Do you connect the radio to Navio2 via UART or USB?

Hi,

I wouldn’t bother buying new telemetry kit.
I’ve got an old set about 6 years old and just recently simply upgraded firmware on it.
It is a good idea to check settings and connection speed / quality by using the telemetry “SIK Radio” tap within MP. This also allows you to upload latest firmware.
Another thing is those usually need to be set for only 57600. - Important to set same speed in your GCS.
If higher speeds are required simply use the UDP or TCP connection via a WiFI router.

Hope this is of some help.