Sumbitting Rinex data to OPUS - File Size

I am always getting a large file size error when I attempt to submit data to OPUS. I know that it only needs/uses GPS data, and that is all I am submitting. Is there a way to also resample the temporal frequency of the data. If I am reading it right, it only uses one measurement every 30 seconds. I can’t see the option to do this in RTKLIB RTKCONV. Does anyone know how to do this?

Thanks

OPUS is a PP (post processing) service using CORS
data throughout the USA. OPUS does not provide PPP (precise point positioning). PPP uses satellite ephemerides to compute a position.

You can submit compressed files to OPUS such as .zip files

Ok thanks for the clarification on the PP vs PPP. That is great information to know. Regarding the zip files, I was already submitting my zip files. Any ideas on how to resample (e.g. decimate) the collected Rinex file?

Most commercial PP software can decimate the rinex data to whatever time interval needed. OPUS automatically decimates all submitted data to 30 second intervals.

You can try this as mentioned in another thread by “wizprod”

https://semisys.gfz-potsdam.de/semisys/scripts/download/index.php

Or you could use “teqc” command line software.

1 Like

Here’s the link to “teqc” software

Hi George,

Yes, you can decimate the data to the particular interval in RTKCONV. Please check the screenshot below. You need to tick the Interval option and choose the time interval in the drop-down list.

However, as Bryan has mentioned, OPUS decimates all recording rates to 30 seconds. So please make sure that the log was recorded no more than 48 hours for the Static method and no more than 2 hours for Rapid-Static. If your log exceeds this limitation, this might be the reason why you get the file size error.

1 Like

But the when ticked, no obs-file is generated.

1 Like

It does not work, the rinex is empty

Hi Christian and Luis,

Could you please set the Time tolerance parameter to 0.025 and convert the file again with the selected interval? I have highlighted this parameter on the screenshot below.

3 Likes

That worked like a charm, thanks.
What does this parameter do, and can it be set to 0.025 as default in the future, so other users won’t have the same weird behavior?

Interested in the response to this question. I’ve always hit a block trying to decimate observation files of 3hz or 5hz to 1hz. Thanks

Hi Christian and Richard,

Time tolerance is an internal parameter of RTKLIB. We’ll make sure that this will be provided as a default in future versions of the software.

3 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.