Stuck with blinking blue light on Reach RS2 setup with Starlink wifi

Hi all,

I re-flashed the latest firmware (August 2023) on my RS2 units using a wifi connection from Starlink. That part of the process seemed to go fine (Emlid Flow V9).

I then need to connect my mobile device and RS2 unit(s) to the same wifi network to do initial setup. I ended up with an infinite flashing blue wifi light the first time I tried using the Starlink wifi. I concluded this is because Starlink allows users to connect to 2.4ghz and 5 ghz simultaneously, and I read here that RS2 can only interface with 2.4ghz.

I then split the Starlink wifi into separate 2.4ghz and 5ghz networks (each with a new and unique name) and tried to do the setup again.

I now find myself STILL stuck on the endless blue flashing wifi waiting for the RS2 to connect to the network to allow me to set the units up.

I’d be very keen to hear any of your thoughts on how I could trouble shoot this issue further (as you may have guessed from the Starlink connection I’m in a remote region and far away from the nearest alternative wifi point…).


Hi Jeff,

Welcome to our community!

I’ve caught your email to and answered you. Let’s continue our discussion there to keep all the details in one place.

Thanks for the help, Kseniaa - my problem is now solved.

In case others are interested, my situation was:

  1. I flashed the firmware using wifi.
  2. I was unable to complete the initial setup because I was having some issues connecting my Reach to the same wifi I used to flash it. Normally I would just try using a different wifi, but that was not an option due to my remote location - there were no other choices!
  3. In my specific case, I only need to use Local-NTRIP and PPP.
  4. I learned I was able to complete the initial setup by tapping on Step 3 of the ‘initial set up’ process in Emlid Flow BEFORE going through Step 2 (the wifi connection).
  5. (My) problem solved! I will try to trouble shoot the wifi connection more when I am back in better contact, but I can go on with my intended work here now.

Hope this helps.