Struggling for a fix

When connected to NTRIP (base station 6km away, corrects for multiple frequencies), I was surprised at the trouble I had getting a fix (rover had 32 sats, base had 38).
I waited over 20 minutes with no luck.
Then I started turning things on and off, experimenting a bit, and in the same location, after turning things on and off, I got a fix within 10 seconds. But if I tipped the rover over and back up, it then struggled for another ~15 mins.

RTK settings: 15 degree elevation mask, 5hz, 35 SNR.

This was connected to an ipad. So I switched to my iphone and it fixed within 10 seconds. If I tipped the rover over and back up, the fix was found very quickly 4 times. Then the 5th it was lost and didn’t come back.

I never saw float, it was either single, or fixed.

Is it preferred/much more stable to have the sim in the RS2, rather than hot-spotting from my ipad/phone?

I also changed Mount points and the same behaviour occurred.

Hi James,

This is interesting, will you be able to share raw logs with us? We’ll need UBX log and RTCM log from the session.

Hi Dmitriy,
Happy to share any data that will help.
I hope I’ve attached the data you require.
James (146 Bytes) (628.8 KB) (452.5 KB) (2.9 MB) (4.8 KB) (41.4 KB)


Hi James,

May I also ask you to share the screenshot of the correction input tab with an opened list of incoming RTCM3 messages? To enable it, you need to click on the “∨” button on the bottom.

The first RTCM3 was empty, check what Tatiana requested.

Hi Tatiana,
Sure thing. See attached.
I tried RTCM2 and I tried send NMEA GGA on/off.

Hi Tatiana,
Any feedback as yet?
Today, same location, I had the same issue. Later this afternoon it would float almost immediately and then get occasional short-lived fixes.
I expected to be able to have no issue at all fixing in this area with the no. of available satellites and a CORS 6km away.
I was hoping to use the RS2 on a jobsite on Monday, but with the lack of fixes I won’t be able to.
Let me know if there is anything else I can provide.
Kind regards,

Hi James,

As I can see, Reach RS2 is getting a lot of information from the caster: MSM7 messages for GPS, GLONASS, Galileo, and BeiDou. In the current dev v2.23 firmware version, we improved the stability of Reach performance while it’s getting a large number of messages from NTRIP caster.

Dev versions are mostly intended for testing purposes and we usually recommend being careful with using them for real field projects, however, I believe the v2.23 should help to eliminate the difficulties you encounter.

May I ask you to update your device and check if it works better? To do that, you may subscribe to dev branch in ReachView Settings.

1 Like

Thank you for getting back to me :slight_smile:
I upgraded to the dev kit this morning and it is now working; which is fantastic.
When is the next stable release due out?


Hi Tatiana, I am strange the comment of version 2.22.4, I use gps, galileo, glonass and beidou and always fixed solutions in NTRIP.
I use a Base and Rover RS2

Hi, as i recall James is only using one RS2 and the base is something els. Topcon or Leica maybe

Yep, I was just using one RS2. NTRIP connection to the AUSCORS service.
They are in the process of adding additional bases to the service and I will have 4 within 12km of me. 2 are up and running. Amazing free service.

Dang, wish I had that here. Here the service is 1.600 EUR a year…

It’s going to be interesting how the AUSCORS service disrupts the market here. Most surveyors use a paid service for ~$3000 AUD/year.


Hi James,

I’m afraid I barely provide you with any estimates at the moment.

Hi Luis,

May I ask you to create a separate thread with the detailed issue description? It helps us a lot :slightly_smiling_face:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.