Strange shift in absolute position

Hello all,

I have a question regarding the post processing of the raw log files retrieved from our Reach M+ and Reach RS receivers. Last week we finally did some testing with our drone and 100mp camera with the Emlid Reach set-up. We first encountered a problem with missing events but discovered that this was a camera issue.

Since we have the correct amount of events, we tried to post process the data with limited succes. We have had the following set up: we placed the Reach RS base (above a previously set up point, just to be sure and to have the possibility to post process the log files with this known coordinate) and connected the Reach RS with the internet to get NTRIP corrections in order to get a quick fix. The Reach M+ plus was turned on and we`v let it sit there for about 5mins so it could initialize on its position We have also measured the height of the antenna from the midpoint of the camera (0.557m).

After first post processing we saw in the report of Pix4D that there was a big shift/error in the XYZ according to the GCP`s we add (these are surveyed by a proffessional surveyor, absolute accuracy around 0.5cm).

We did not expect this because of the fact that we connected the base with NTRIP. We do think that relative positions is good but what we are looking for the absolute accuracy and therefor we would like to see that the error is less then 5cm in all directions.

After trying several settings we discovered that when we feed the coordinate + height of the known point along with the antenna height (1.7850m = height bottom side antenna + 65mm) the results became better but not as we want it to be.

However the Sigma in both reports are really good. (within 1.5cm in all directions).

Do you guys have any idea on what could be the problem? I think something is wrong with transformation of the coordinates but dont know for sure as we have tried different programs and settings in RTKLIB. I don`t know if this is to much to ask but maybe one of you guys could process the data to see what results we get.

The know point coordinate we used is: 228235.985, 582067.725, 0.437 (RD Amersfoort datum with NAP height) transformed to WGS84 is 53.220206867N, 6.483669136E 41.1962 (meters above the elipsoid).

Hope you guys can help us out. By the way I cannot upload the log files because i`m a new user. Maybe I can pm it to someone?

Kind regards,

Lammert de Graaf

You can use dropbox, google disk or onedrive and share link to your files.
I might take a look at your project.

Hi there,

Of course. I could have thought about that earlier. my bad. Here is the link:

At first glance according to this tool, the transformation you postet is a bit of.

What do you get if you rerun with the above base coordinates?

This is what I get when I enter the coordinate in my program. Does not seem like it is off that much but its still off by 10cm. I will try and process it with these coordinates. Do you also have a tool for transforming the height?

Can you include Pix4d processing report as well?

Of course. Here it is…Test PPK Hoogkerk V5_report.pdf (258.2 KB)

Maybe you had a false first fix, what are processing options chosen? Kinematic and continuous or kinematic fix and hold? Have you tried processing as static-start in RTKPost?


I’ll take a look at Pix4D report as well.

1 Like

Hi RTK Hunter, Thanks for looking in to it as well. I attached the config setting which I can save in the options menu of RTKpost.output (1.7 KB)

As for the settings I used kinematic with fix and hold. I will read the article to try and learn about the static start. Maybe it will help

What is the coordinate file you are giving to Pix4d to define output coordinate system: Amersfoort /RDNew(EGM96Geoid)?

Yes that is correct. That is the coordinate system we use in the Netherlands or is being used by our government

Sorry, to be more clear: Is this included default in Pix4D or did have to provide coordinate file to define? I couldn’t find in Pix4D…

Edit: Found it. Looking in wrong directory…

Yes it is included. You have to type in this: Amersfoort / RD New when searching in the know coordinate system. I believe it is EPSG number 28992

oops sorry didnt read your whole comment haha

I have four transformation parameters possible out of QGIS from RD Amersfoort to WGS 84:

I went with first one and got the following: WGS84=53.220206256N 6.483668302E

The difference in my transformation from QGIS and yours is this:

It might be as simple as transformation error. Try running RTKPost with the above QGIS transformation for base coordinate and run as static-start for rover.

Other suggestions: Make sure your coordinate definition is same as surveyor. Make sure these coordinate definitions match those stored in Pix4D. If don’t match upload the coordinate/projection file to Pix4d of the correct one and reprocess dataset. Good luck.

I was having strange behavior on static-start. Went to kinematic - continuous - GLO On. Run with the following configs in the file with the above base coordinate (should be saved in there) with my events log. I didn’t bother with Z-value… (16.8 KB)

Curious if this gets you closer.

Thanks for the help! :blush: I will process the data and see where it will get us…

To be continued… :wink:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.