Strange reachview behavior?

Today, all of a sudden, I am having a weird problem. I am having trouble accessing ReachView on one of my RSs.

I normally have the Reach units log onto my cell phone hotspot, and then I access them through that network. Today, when I turn on my rover, it logs on to my hotspot like normal, but it seems to respond inconsistently when I surf to it in my browser. When I type in the local IP address on my phone, it will start to load and then freeze. If I hit refresh a few times, it will eventually give me the Emlid logo, but maybe not change from grey to blue. If I refresh a few times, it will change from grey to blue, and then seem to take forever to open the main screen. If it DOES open the main screen, it will maybe not show me any live data coming from the device. If I change tabs, say to the correction input page, it might show me a spinning wheel and not load the page showing the current settings, though sometimes it will show me the actual settings. And then it will eventually give me a red box warning in the corner saying it has lost the connection, forcing me to start refreshing all over again.

This is really frustrating behavior I have not seen before. And I am supposed to be sending this equipment out to do some fieldwork in a few days. I just did come training with colleagues them on it yesterday, and all seemed fine.

Anyone have any suggestions?

Also, if I go to the IP address plus “:5000” I get the upgrade page responding normally.

Hi Austin,

Could you please let us know which device/browser/os you are using?

I have tried with my iPhone in Safari. On my mac in Safari and in Chrome. On an android tablet in Chrome. All ways I had been successfully accessing it up until now. I have also tried letting it start its own hotspot, and have the same issue.

Now, for the last 20 minutes or so, I have not been able to get past the Emlid logo.

I have tried clearing the browser cache on both my mac and iPhone. And, when I was intermittently able to access ReachView, I tried hitting “reset settings to default”.

Waiting at the end of the Emlid Logo screen for several minutes, I did just get into the main screen, and did get to a settings page.

I also AM getting output data via bluetooth to my data logger.

Hello Austin,

Seems like a weird issue. I will need some additional info on this:

  • App version
  • Did you actually manage to perform “reset to default”? If you did, did it actually change anything?
  • Did you use the new point collection features in ReachView?
  • Is there a chance the internal memory dedicated for gnss logs is full?

This type of behaviour might have started due to a number of reasons, most likely some internal config file got corrupted.

If you are in a serious hurry, I would suggest reflashing the device right away.
However, if you have the opportunity to help us debug this, you could:

  • ssh into the problematic reach
  • run journalctl -u reach_setup --no-pager > reach_crash_log
  • download that reach_crash_log file via rsync or filezilla
  • PM it to me


Sorry for the delay responding. I was getting really worried about this when it started happening, because I was about to send my supervisor out with the equipment to do field work for the first time (I just trained him and his grad student on it this past week), and was really worried that I was running into this problem with accessing reach view and it would impact their ability to do fieldwork.

  • When I had tried to “reset to default” I wasn’t sure it had actually gotten through or not, because lots of things (changing tabs, saving settings) were timing out in the browser and not showing whether they had completed or not.

  • I HAD used the point collection in reach view previously, but not for several days at least.

  • There is NO chance the internal memory is full, it just hasn’t been run that much. Though I will check

Because there was such limited time to get this sorted out, and since it WAS apparently outputting data via the BT connection as it should, I did manage to get into reach view enough to change the settings needed for the rover to be ready for the fieldwork we were sending it out on (switching the rover back to LoRa radios rather than NTRIP), and then the system seemed to be set for the fieldwork. I was not having problems with accessing the base station so they should not have problems inputing the base coordinates. This is not ideal, but it hopefully lets them still do the fieldwork as planned (it is happening right now). After several hours of having the trouble I described, I was then, just before they left, able to access reach view more normally the last one or two times I tried to surf to it.

So the upshot is that I have not reflashed it, and when they get back from the field on Wednesday, I can try to grab the file and send it.

Thanks again for the quick responses! and sorry I did not post back here sooner.

I had the same problem as you.And sometimes i restarted Reach then i could access Reachview successfully,but usually i had to refresh the firmwire.
Do you have any other solution?

Some news on this issue. It seems we’ve found the bug that caused this behavior. It is related to opening the app page in certain situations, especially when the connection is slow for some reason. The fix will be out in the next update, hopefully we won’t see this again.


This is great. Thanks Egor.