Status remind single without grey bars

I’m trying to integrate RTK with Pixhawk (PX4), in process pixie and drotech rtk where successfully implemented.
Now, I’m working with Reach RTK and Navio+ with RPI 3.
First I started with implementing Reach RTK (ReachView V0.4.6, Reach image v1.2, RINEX version: 3.02) with Pixhawk (px4-reach/ArduCopter-quad-v3.3.3-ERB.px4). I followed everything as per :
with 3dr 915mhz.

In rover status page I’m getting more then 6 sat’s above level-45 without grey bars and status remains single more than 20min no change of status.
The settings are given bellow….

After this I thought of checking the working of Reach and used tcp server and client model. And also I tried direct 3dr radio connecting to reach modules with serial uart 57600. On all this attempts I’m getting the same response (“rover status page: I’m getting more than 6 sat’s above level-45 without grey bars and status remains single more than 20min no change of status”).
Other thing I found in all this case is, by absorbing log page of rover, the reference file is empty.

I’m also attaching the log file bellow… (8.6 MB)

If rover stays in single that means that connections are not getting through. When testing with TCP did you configure rover as TCP client?

I kept base as server with a port (/ip_b>:9000) number and given server ip and port number (<ip_b>:9000) as input to the rover and rover output in a port (/ip_r>:9001).

When I browse both the port say:
/ip_b>:9000 -- RTCM3 file start to download continues, With Mission planner GPS Injection is also happening properly from the base (data from base goes out)
/ip_r>:9001 -- IIh start’s to print data in the browser tab,

But still my rover window status is single for more than 20min and there is no grey bar are near to the rover sat bar……

Please try to debug the connection. No grey bars means that there is no communication between two modules.

If you set the base unit as a rover does it show green bars?

Yes, when i set base as rover it shows green bar… But still if my network has some problem also, the 3dr radio direct connection has to work na…

Base_settings for 3dr radio
o/p->serial->USB-> 38400 and 57600 (both where tried).
o/p_format -> RTCM3 MSG-> (3,6,9 & all)
b_U-blox config file -> GPS_10Hz, 5Hz, GLONASS_5Hz.

Rover_settings for 3dr radio
i/p ->serial->uart->38400(only 38: for pixhawk) and 57600 (both where tried), format -> RTCM3
o/p-> serial -> uart-> 38400(only 38: for pixhawk, with erb format, In MP i found the copter keep moving randomly)
other-> o/p id off.

Please check that RX and TX lines are not mixed up. TX should be connected to RX and vice versa.

Yes, Tx and Rx is mixed Up, But one more last question before starting my next attempt. with pixhawk integration wiring and setting seems to be correct but i got the same o/p.

And i have a small request for the team, Pls give us some video demonstration for setup which will make us to understand and work faster. Docx are good, but sucks time. Pls do consider this.

I’ll correct the wire and do test tomorrow and give you ack. thanks for you time…

Things are working fine after Tx and Rx changing. Pixhawk integration is also working fine. I’m not using any primary GPS and using only RTK, so I’m getting no GPS: No GPS in MP. Is there any way to fly without primary GPS (or) have I need to use some primary GPS along with RTK as secondary?

You can set in ArduPilot parameters Reach as primary GPS by changing the ports.

1 Like


Hope i have good signal strength on both base and rover but still my rover reminds float even after 20min…

I’m seeing:

  • 6 “R” satellites. (1 is bad strength)
  • That should allow glonass ambiguity resolution (AR) if it is enabled.
  • 3 “G” satellites. (maybe more off-screen)
  • If you have 2 more off-screen and they are over the minimum SNR (default 35), then that should allow GPS AR.
  • 1 “J” satellite. I’m not sure if it can be counted with GPS for AR or not. Maybe it will only be used for error-correction.

I think I’m safe to say that where you read “AR,” you can think “fix.”

Can give me some more clear idea on this. So you are saying me to consider this as fix.

And one more, when use gps_glonass_5hz i’m at least getting float mode, but when i use gps_5hz its even more worst, i can see both green and Gray bars above the threshold level but the system still reminds in single. This is crazy, can any please give some idea in point why should i use only gps_glonass and not others…