Stakeout - Distance flips to Direction with Bullseye

When in Stakeout with Distance mode selected, when close to the point and the Bullseye comes up it suddenly changes to Direction mode.
Move a couple centimeters back out of Bullseye range, and it flips back to Distance again. And so on.

It’s doing my head in. Nice N,S,E,W, all the way then suddenly in the last 2.5 cm it’s now spinning in my travel direction. But I’m not traveling. It’s only the tip moving under that wonderful IMU but the tips directions of movement aren’t computing at all in my mind with the travel directions rotating on the screen.

And this is where Distance mode is really needed.

How can I force it stay in Distance mode with the Bullseye up?

Thanks

2 Likes

I see that to , the screen is constantly rotating

1 Like

Hi Wombo, did you use Emlid Flow 10.8 when you encountered this issue?

Hello Merrryna,

I believe it was as I do regularly update, and I distinctly recall having just done so prior (because I was then wondering if that had been a smart move after all)…but I didn’t specifically look at the version so can’t say 100%.

Thanks

Sorry for the delayed response. I tried to reproduce it and can’t get the same behavior. Do you still face the issue?

Yes, I’ve just tested again and it is definitely still misbehaving.

What I can add is that behavior is normal if IMU is disabled. Stakeout remains in Distance mode once selected at all times. Including before, when bullseye comes up, and after bullseye is gone if you moved back. All is good.

The problem exists when IMU is enabled and stakeout is set to Distance mode. As soon as you get close and the bullseye appears, stakeout correspondingly flips to Direction mode (with the ugly Azimuth suddenly appearing in in your face). If you back off, the moment the bullseye disappears so does Direction, with Distance reappearing.

Put simply, with IMU enabled Bullseye is locked with Direction/Azimuth.

It is consistent and repeatable.

App version is 10.9

2 Likes

Hi Wombo,

Thanks for all the info! I tested it on iPhone and Android and can’t reproduce the issue. Could you share:

  • Reach Firmware
  • Phone type
  • Android/iOS version

Additionally, a screencast will be really helpful to investigate this issue. Thank you!

Hello Merryna,
That’s very interesting you can’t replicate it there. I’ve done more testing and the behavior remains consistent for me on each and all of the following regardless of the Mobile/RS3 combinations:

Samsung XCover7 - Android 14 - Flow 10.9
CAT S62 Pro - Android 11 - Flow 10.9
ZTE T86 (Telstra Tough Max 3) - Android 10 - Flow 10.8
RS3 #1 - 32 beta 5
RS3 #2 - 31.8

A couple of differences could firstly be the coordinate system, I’m using GDA2020 but tried setting up projects Global CS and WGS84 UTM and it made no difference.

The other obvious possibility is that I’m in the southern hemisphere, but I can’t do much to change that right now.

One change to what I reported above is that I’m not seeing it drop back to distance when I back off, it jumps from Direction to Azimuth and remains in Azimuth. Not sure what I am doing different to previous.

A link to a screen video example in Dropbox doesn’t come up as active here so I have emailed it through to support.

In summary these screenshots show what I am seeing, firstly with stakeout set to distance and approaching the point:

And the moment I cross the threshold and the bullseye appears, bam, it immediately jumps to direction: