Spektrum DX6i -> Lemon RX DSMX -> PPM - Problems

I have just recived my Navio2 and can´t wait to start using it.
First of all I´m kinda new to all this so it may be that it is something obvious I´m missing.

My Problem:
I can´t get any RC signal from the Spektrum trough Lemon RX to my Navio.

My setup:

  • Spektrum DX6i, 6 Channels
  • Lemon Rx DSMX Compatible PPM 8-Channel Receiver + Lemon DSMX Compatible Satellite with Failsafe
  • DJI E300 tuned propulsion system for multirotor
  • Hyperion 3S LiPo
  • Raspberry Pi 2 B
  • Navio2
  • Power Module

I have successfully binded my Spektrum with the Lemon RX. The Lemon RX outputs an 3,3V ppm signal. I read in topic “PPM-decoder problem” that 3,3V was to low and that I would need to remove R8 from the Navio board to cancel the voltage divider on the PPM pin. I did that, but still nothing.
I have installed APM Planner 2.0 on my MAC and I have started the “sudo ArduCopter-quad -A udp::14550” on the Navio. Telemetry works fine, when I tilt the Navio the “HUD” tilts as well, but still no RC signal. The “PreArm: RC not calibrated” is still going strong…

Does anybody have any clue on where I should start to look or what to do?
I hope the information is sufficient, if not give me a hint and I´ll find out

Links:
Spektrum: http://www.spektrumrc.com/Products/Default.aspx?ProdID=SPM6610
My Spektrum setup: https://www.youtube.com/watch?v=Vxlh3DitlBs
Lemon RX + Satellite: http://www.lemon-rx.com/shop/index.php?route=product/product&path=72&product_id=118
DJI E300: http://www.dji.com/product/e300

You should not do it on Navio2, that information was valid for the old Navio only. Navio2 will accept both 3.3V and 5V PPM without any modification. You have actually disable one of the channels on RGB LED by removing R8 on Navio2.

Could you please provide a picture of how everything is connected? Can you try with MissionPlanner as well?

Okay, so I have soldered the R8 back on and i tok some pictures.

As of the mission planner, I can´t say I got any further. The PreArm-error is still there and when i try to hit “Play” i get "FAILURE: Unsupported CMD: 252, if i try to hit the “Take of” button i get "FAILURE: FailedCMD: 22

Any ideas?

btw. The reason why the power cable is disconnected from the ECS´s is because they make a lot of noise when there is no signal present.

It is normal that you are getting prearm check error. When you go to RC calibration window what do you see there?

The RC calibration window is totally blank. Only black bars

Please run this command on your Pi:
cat /sys/kernel/rcio/status/alive

It says 1

cd /sys/kernel/rcio/rcin
sudo cat connected

Then ls. This is where you’ll see the channels. You can look into your problem a little bit by moving sticks and checking if the values you see in the directory you just issued you command in, do match.

Okay so I “ls” in this folder, change the stick position then “ls” again, but I can´t se any change.

Something I´m missing?

Edit:
In the folder I have ch0 through ch7 and connected

Sorry I was a bit hasty. I have gone through and used “Sudo cat ch0” and so on, and I can see that the values are changing as I change the sticks position.

So if I under stand this correct, the PPM signal is coming in to Navio, but it is something wrong with the interpretation?

Ok, so your hardware is fine. Did you install APM from the link in our docs? Can you try a fresh install?

Thanks! It was an software problem, something must have gone wrong in the first installation. I now have the green bars in the Radio Calibration tab! :smiley:

But now I have another problem when i try to calibrate the radio I get “Radio Control is not active or turned on”. And at the same time the LED has started to flash red and green (basically yellow) with two short flashes continued with a short break then two short flashes again.

Any ideas?

Good! Is this behaviour consistent between APM Planner and Mission Planner?

I can´t check if the behaviour is consistent, because I for some reason cannot establish an connection.

I have tried to install everything again and this time I use my windows 10 where I have installed Mission Planner and APM Planner, but still no luck.

I still get the same “Radio Control us bit active or turned on”. Which is bullshit, because I can move all the 6 green bars :confused:

Anything else I can try?