[SOLVED] Using RTKLIB on a RasPi with NAVIO+

I am using a Raspberry Pi B+ to run RTKLIB. I have followed the instructions to connect the Raspberry Pi and NAVIO+ using the GPIO pins and the header from here:


Next, I followed the instructions here:


However, when I type in “status”, I get all 0’s.

Am I missing something here? I have followed all of the instructions very closely, yet I am not getting any results.

Also, I have already tried changing:
file-cmdfile1 = …/data/ubx_spi_raw_5hz.cmd
file-cmdfile1 =…/data/ubx_spi_m8n_glo_raw_1hz.cmd

Any sort of help would be greatly appreciated!

@midoy192 Hi, could you please try GPS example app and see if GPS works? It’s explained here - http://docs.emlid.com/Navio-dev/read-gps-data/

I do have exactly the same problem ( rapi B+ and navio +)
I did exactly the same thing, and even the gps example does not work. If I use the default Rasbian, then the GPS test work, but not the rtklib…

If it can help you, barometer, gyroscop, acc and magnetometer works fine (in both Rasbian and your rasbian_RT)

Thank you for your help!

I can’t find the raspberry pi B+ SD card image.
I did use the raspberry pi 2 image.
This is certainly the reason why my setup does not work.

Is there a place to find the correct image? (Mega link does not work)

@Philippe_Vimont Hi, the link to the image has been fixed.

Ok, i’ve tested and … It works!
Thank you !