[SOLVED] Unable to connect Navio+ to APM Planner v2.0.18 through Ethernet


I recently purchased the Navio+ Board and would like to establish communication between the raspberry and computer through Ethernet cable, as a first test.
In the future, I plan to use a WIFI dongle for telemetry.

When I run the following command
sudo ArduCopter-quad -A udp:
nothing happens

APM Planner looks like this:

Here is a recap of the steps I’ve performed:

I have downloaded the Emlid Raspbian version available here:

I have configured Ethernet and WIFI on the raspberry Pi.
Raspberry Pi IP address is :
Computer IP Address is:
Currently, I’m using an Ethernet cable connection.
The Raspberry and the computer can ping each other.

I have installed APM Planner v2.0.18 on the computer and, in the communication menu, I’ve left UDP Link (port 14550).

I have downloaded and installed apm on the Raspberry:
wget http://emlid.com/files/APM/apm.deb
sudo dpkg -i apm.deb

apm is listed in the installed packets:
dpkg-query -l

Have I done something wrong or missed a step?

Best regards,

I was also struggling with communication. I tried using the address of my raspberry instead of my PC, eg. sudo ArduCopter-quad -A udp:(Raspberry address):14550. That seemed to work. The next thing you have to do is set up a communication link in the apm mission planner on your PC. Go to the communications tab, delete all the existing links and the create a new udp link with the details specified in your ArduCopter-quad command. Then hit connect.

Remember to use the same port number and IP address when creating the communication link in apm mission planner as you did when you ran apm on the raspberry. From your second figure, it does not seem like the link details match your previous command.

Thanks Nicholas,

Now I type this:

And in APM Planner, I configure like this:

I still have no telemetry data on APM planner.

Any idea?

Thomas, have you tried using TCP instead of UDP? Here are the steps that worked for me (I did not try to use UDP so I am not sure what might be going wrong with your communication link):

  1. Plug raspberry pi into modem using ethernet cable
  2. ifconfig to find out raspberry IP address (in your case
  3. Now run sudo ArduCopter-quad -C tcp:
  4. See image below for the output of the previous step
  5. Now open apm mission planner, and set up the communication link. This is show below.

    Note that here you should replace the with
  6. Finally, hit the connect buttom.

Hello Nicholas,
I’ve followed the steps, but unfortunately it doesn’t work…

Unlike you, I don’t have any output, nor error message, when I enter this command on the Raspberry.

Nothing happens when I click the connect button.

Is there any way to check that “ArduCopter-quad” program is correctly installed and running on the Raspberry?

Problem solved.

I just re-installed everything with the 2nd image available here:

I think I was not using the correct image…

Thanks a lot for your help Nicholas!

Hello Thomas,

These two images are identical, so the problem was probably in something else.

1 Like