[SOLVED] Two new Reach RS+'s - after update, Green light blinks on both units (not accessible via hot spots)


We just took delivery of two brand new Reach RS+'s today. We quickly updated to latest firmware and all seemed ok.

Until we did a restart on both units. Now we have both a flashing Blue and Green lights. (first light is solid).

Now we do not see the Reach available within the Reach application on iOS. Also, we do not see the Reach RS+'s via their own Wifi (which makes sense as the blue light indicates they are connected to a network.)

Any idea on how we can get them back on the app? and yes, our iOS device is on the same network the two Reach RS+'s are on. Still nothing when we click “refresh” in the app.

Any help is appreciated. Thanks

Ok to be clear, my issue is the following [both units **
GREEN LIGHT** blinks on and off]

I took both units home with me and now, the blue light goes solid (indicating it is emitting a hotspot) which I can confirm BOTH units are. However, when I connect to their hot spots via an iPhone or iPad Pro, they are not accessible through the ReachView 3 app. Ive tried just about everything I can think of to get them to show up. they just don’t

The Green lights on both units just blinks on and off. I even tried setting them outside for 15, 20 minutes, still nothing.

I also tried to access ONE of the units IP address via a web browser (including the :5000 trick) and still nothing.

What is going on here? Please help.

Hi @ehcropydoc,

Welcome to the community forum!

This behavior is not how the Reach RS+ should act. Please share the serial numbers from both devices with us. You can either send them to me in PM or to support@emlid.com.

On the latest firmware versions, you can access the Updater page by typing the <Reach's IP-address>/updater_panel in the address bar of your browser. Please try it and share the screenshot with us. This is needed so that we can see the self-tests of the units and assess if there are any issues with them.

I made made the attempt this morning to try the /updater_panel trick. Still nothing.

I can only try on one unit as I didn’t write down the other unit’s IP address when doing the initial update.

Also, I can’t seem to find the way to PM you here so I will draft an email to support. Not the way I wanted to start with a new product. I really hope this is something obvious.


I can see that your units are transmitting the hotpot. This means that they have a known IP address:

So when you connect to the unit’s network, to achieve the updater page, you need to type:

This can be applied to both units once you switch between their networks. Please check if you can access the Updater page this way.

Ok so I managed to get brief access by entering in the same IP address you provided but with the :5000 trick. The one provided did not work.

However, I then am brought to the page where it says “Tests” which all show good and underneath is the WiFi. I only have the ability to get it added to my local WiFi which I tried on one unit.

So now I have one unit connected to my local home network and is not emitting a hotspot any longer. This unit is inaccesssible via the web or via the reach app. I’ve tried both numerous times with not the :5000 url and the one you provided.

The other unit is still at this step (as I did not add it to my local home WiFi):

Issue resolved by flashing both units to 26.3 - still no idea what caused them to go out of wack


Hi @ehcropydoc,

Thanks for sharing the solution!