[SOLVED] RC Input fault finding

Hi All,

I’m not having any luck with NAVIO2 receiving or showing any RC inputs. I’ve tried a FrSky Delta 8 outputting CPPM to NAVIO2, FrSky X6R outputting SBUS into NAVIO2, as well as the using an SBUS to CPPM converter to NAVIO2.

When I go to the initial setup and radio calibration page in Mission Planner however, there appears to be no RC inputs. I’ve checked that the transmitter (Taranis X9E) is connected to the reciever. The receiver is connected to the correct pins in the correct way on the NAVIO2. I’ve also checked that the receiver outputs data, but I’m not seeing any evidence of that on Mission Planner

All of the C++ examples work except for the RCInput and servo examples, and I can receive telemetry via both UDP and ttyAMA0 which suggests to me that everything else is working ok.

I’m using a RPi2, NAVIO2 with the 20160212 image and a fresh SD card with APM installed from the deb package linked in the NAVIO2 documentation .

Incidentally, when I run i2cdetect the only address that comes up is 77, yet I still get telemetry.

Anyone spot my error?


@vinnie Hi! Could you please run the following commands and post their outputs?

cd /sys/kernel/rcio/rcin
sudo cat connected
uname -a

@mikhailavkhimenia Thanks Mikhail. I did as you suggested and initially got a return of 0 for sudo cat connected. Double checked that there was an output with my oscilloscope directly from the reciver which there wa, then on a whim checked the wire. Tuns out the wire was toast. Changed the wire and now it works.

Valuable lesson there.

Thanks for the help.

1 Like