[SOLVED] Random No RC Input, Navio2 + Raspberry Pi 3 Model B + X8R + S.BUS

I am not getting consistent RC input.

sudo cat /sys/kernel/rcio/status/alive

will return 0 about 90% of the time.

Occasionally, it will work and with perfect data. If I power off the Navio2 and restart it, it will not work with the same hardware configuration.

I cycled though all my possible hardware configurations and binding options with no consistent results.

I tried the same tests with a D8R-XP with no success.

What can I do to diagnose the problem?

Raspberry Pi 3 Model B


Tried Receivers:

I have confirmed both receivers are bound and working.

Tried SSD cards:
class 10
class 4

Fresh image:

1 Like

I just had an issue using sbus, but it wasn’t recognizing rc channels 9+. See my post here.

Maybe try running the update commands staroselskiy mentioned. Also maybe try these commands mentioned when you think the receiver is not working. Seems like you could narrow down if it is software or hardware issue.

What caught my interestin your post was that while troubleshooting no rc ch9+ pwm I was changing modes on my receiver (futaba 7008sb needs to be on mode 2 to output sbus… maybe your receivers need the same configuration??) and it was easier to power cycle the receiver by unplugging the cable going into sbus rather than powering down the whole system. When I did this I had the same results you are now. Receiver showed connected to the transmitter but navio2 didn’t see any pwm input. I would restart and try again but it was intermittent. Because I was still troubleshooting I said screw it and reflashed and built the experimental branch using waf and all seems to be working. Haven’t flown yet but have tested all rc channels and powered the motors up.

Oh and I am also using rpi3 with navio2 and the latest rt kernel image.

Thanks for the suggestions.

I am not running APM yet. I am still trying to get the C++ RCInput test app to function.

As a sanity check, I had a friend bring over a known to be working S.BUS Futaba R2008SB setup. The results were the same:

sudo cat /sys/kernel/rcio/status/alive

returns 0

Since I was able to get it to work occasionally with my X8R, I now believe there is a bug in the image release emlid-raspbian-20160408.img or there is a hardware fault in the Navio2 or Raspberry Pi 3.

1 Like


Have you fixed Navio board with screws? The issue you described looks like a connection issue.

Fixed! Thanks.

Although I did have it screwed down it was a contact issue.

I removed the board, shot some compressed air on both boards contacts, cleaned them and reattached it. It
fixed the connection issue and I now have steady RC input.


I’m glad that’s sorted out. Happy flying! :helicopter: