[SOLVED] Random motors movements after esc calibration

I am encountering a weird issue with my Navio2 board.
I configured my quad, as explained, then calibrated my ESCs (Everything works fine).
After the calibration (I disconnect and reconnect the battery), on reboot, the motors start to spin randomly and continuously (My motorized gimbal does so, therefore, It is not related to the ESCs).
Any idea about that?
I am not very experienced with APM,so maybe I miss something…

Another info,my ESCs need arming (Max throttle then Min throttle) at every startup, and I cannot figure out If APM does that or not.

Could you please disable gimbal and try again? There’s an issue with AUX channels at the moment. We’re working relentlessly on fixing this one.

I tried that,but I have the same behaviour, the motors spin a bit then stop continuously.Note that during the calibration process, It works perfectly.

Maybe It is due to the fact that on startup, the min pwm is output?!In my case, I need the max PWM output (for 2 seconds at least) then the min PWM.I could not find any parameter allowing me to do that.

1 Like

Effectively, this is due to the fact that Navio outputs the min pwm at the beginning (The ESC are then not properly armed).
How can I do to output the max pwm on the startup then go to min pwm?Or, in the worst case, make Navio not output anything on startup.

It is a bit frustrating,even a 15 $ board allows me to fly…Anyone got an idea?

That sounds strange. What is the ESC model?

ECTimer ESC 30A Yellow serie,
So, in my case, I need either the correct sequence or no signal output (There is a parameter called ARMING_REQUIRE, but I could not find It).

I fixed the problem by trimming the RC (The send value was incorrect).

1 Like