[SOLVED] Radio Telemetry won't start?

I get this when I try starting telemetry through the radio:

pi@navio-rpi ~ $ sudo ArduCopter-quad -C /dev/ttyAMA0
Raspberry Pi 2 with BCM2709!
0

Init ArduCopter V3.3-dev (9e506e97)

Free RAM: 4096
FW Ver: 120

load_all took 114us
0 0 0 ▒ Q}▒▒3▒Initialising APM…▒}▒ Q▒
Press ENTER 3 times to start interactive setup

▒3▒Calibrating barometer▒▒▒ Q▒.▒3▒barometer calibration complete4Z▒3▒GROUND START▒AInit Gyro▒ Q▒INS

G_off: -0.01, -0.00, 0.00
A_off: 0.00, 0.00, 0.00
A_scale: 1.00, 1.00, 1.00

Ready to FLY ublox ▒ Q▒ Q▒▒▒
Q▒C▒
Q%=▒
QH3▒ Qv▒▒ Q▒▒▒ Q▒▒▒ QE▒▒ Q{z▒ Q▒▒ Qt▒ Q▒
▒3▒PreArm: RC not calibrated▒▒▒ Q(▒▒ Q▒h▒ Q&▒ Q▒▒ ▒▒▒ Qu▒▒ Q▒▒PuTTY▒ Q▒f▒ QK▒ Q▒▒▒ !Q-▒▒ "Q ▒ #Q▒w▒ $Q~▒ %Q▒y▒ &Q▒▒▒ 'Q@▒▒ (Q▒ )QNe▒ *Qp▒▒ +Q▒▒▒ ,Q▒▒ -Q▒▒ .Q▒▒ /Q#k▒ 0Q"▒ 1Q▒\▒ 2Q▒▒▒ 3Q.▒▒ 4Q▒▒▒35▒PreArm: RC not calibrated?▒▒ 6Q},▒ 7Q▒R▒ 8Qs▒▒ 9Q▒▒^Cpi@navio-rpi ~ $
pi@navio-rpi ~ $

And suggestions what is going on?

Forgot to mention that UDP works perfectly, right off the bat.

You mean messages in the console? You see them because you didn’t specify -A port and APM outputs MAVLink together with other stuff to the console.
If radio is your main telemetry channel I’d suggest to use -A options for, but don’t forget to set the proper baudrate parameter for it before (when connected over UDP for example).

If I remember right, I did try it with -A and got the same results. I will try it again in case I’m remembering wrong, thanks!

So I’ve been trying for a few days and still having the same issue. When I do sudo ArduCopter-qud -A /dev/ttyAMA0 I get:
read failed - Success
read failed - Success
read failed - Success
over and over until I kill it.

I think I’m able to see the radio settings by going to additional hardware and see that my radio has a baud of 9.

so I tried this command (kind of guessing how to change the default baud rate): sudo ArduCopter-qud -A /dev/ttyAMA0

That give me the same text output like:
Init ArduCopter V3.3-dev (9e506e97)

Free RAM: 4096
FW Ver: 120

load_all took 114us
0 0 0 ▒ Q}▒▒3▒Initialising APM…▒}▒ Q▒
Press ENTER 3 times to start interactive setup

▒3▒Calibrating barometer▒▒▒ Q▒.▒3▒barometer calibration complete4Z▒3▒GROUND START▒AInit Gyro▒ Q▒INS
G_off: -0.01, -0.00, 0.00
A_off: 0.00, 0.00, 0.00
A_scale: 1.00, 1.00, 1.00

Ready to FLY ublox ▒ Q▒ Q▒▒▒
Q▒C▒
Q%=▒
QH3▒ Qv▒▒ Q▒▒▒ Q▒▒▒ QE▒▒ Q{z▒ Q▒▒ Qt▒ Q▒
▒3▒PreArm: RC not calibrated▒▒▒ Q(▒▒ Q▒h▒ Q&▒ Q▒▒ ▒▒▒ Qu▒▒ Q▒▒PuTTY▒ Q▒f▒ QK▒ Q▒▒▒ !Q-▒▒ "Q ▒ #Q▒w▒ $Q~▒ %Q▒y▒ &Q▒▒▒ 'Q@▒▒ (Q▒ )QNe▒ *Qp▒▒ +Q▒▒▒ ,Q▒▒ -Q▒▒ .Q▒▒ /Q#k▒ 0Q"▒ 1Q▒\▒ 2Q▒▒▒ 3Q.▒▒ 4Q▒▒▒35▒PreArm: RC not calibrated?▒▒ 6Q},▒ 7Q▒R▒ 8Qs▒▒ 9Q▒▒^Cpi@navio-rpi ~ $

By the button that says “connect” if I don’t have that at 9600, I can’t load the stuff from the radios.

Any ideas?

Are you connecting to your RPi over ssh or do you use an hdmi display?

Try to set up radios without the APM first.
Use “screen” or “minicom” to open the serial port on RPi and “realterm” or “teraterm” on your computer.
When you start these programs on both ends and type some text on one it should appear in the terminal on the other end. Mind the baud rates.

I’m connecting to the navio/pi through ssh using putty. I will look into using the commands and tools you mention and let you know what I get.

Thanks!

I’m not able to get anything (or figure out the right commands). Is it possible to have a bad set of radios? Should I get a different pair and try again?

Are you sure you have set the correct baud rates with missionplanner? I set serial0 and serial1 baudrates to the baudrate of my telemetry radios (57600 baud).

Do you have the telemetry radios with micro usb and uart on both modules? Usually called v2?
Then you can test them with your computer directly. I use a programm called Hercules to do this. http://www.hw-group.com/products/hercules/index_de.html
Connect both radios to your computer and start Hercules two times. Select the serial tab for both and select the com port of the first radio in one instance of Hercules and the com port of the second radio in the other instance. Also select the correct baud rate for both. Click the open button on both.
Now you can type text in the lower part of the hercules window and press send. The text should appear in the upper part of the other hercules window. This should work in both directions.

I didn’t know about this and went and looked. When I load my radio settings in mission planner (the screenshot) I get stuff for both radios, so it seems like they can talk. I saw that the baud was set to 9. I went into that setting you mention in Mission Planner and changed them to 9 as well. I still wasn’t able to connect but I will play around with that. I feel like that is closer to my issue. For now I have it configured using udp and got some settings saved.

I think I’ll come back to the radio issue later, I want to take it outside and try flying it with just a controller. After that I’ll come back to the radio so I can get follow me using my phone working.

There are two baudrates for the telemetry radios. One is for the usb/uart connection and the other is the communication speed over the air between two radios.
9 corresponds to 9600 baud and that is really slow, even for radio to radio. You might get problems, because of the amount of data APM tries to send over such a slow connection. Default for USB/UART is 57600. I can not remember default airspeed, but I have set mine to 19200 and it works. You might have to set it higher for follow me and GCS control.

Well, I read that I won’t be able to autostart ArduCopter if the network isn’t available. So I’m back trying to figure it out.

I’ve been trying to use screen and minicom to open up a terminal session. Whenever I do it on the Pi (I’m connected through ssh, is this a problem?) I just get a blank screen and am not able to do anything (if I use screen, I have to restart my session cause I can’t even get out. In minicom with this command 'minicom -b 57600 -D /dev/ttyAMA0, I get the following and am unable to do anything:

After playing around with it more, I’m still unable to proceed. I think my next step is to try a different pair of radios. Any suggestions on what people like? the 3DR one’s have a steep price it seems when compared to others that are fairly easy to find online.

Take a look at the newest beta. It might solve some of the issues.

There’s a magic key sentence to get out: CTRL-A K. So no need to restart a session!

thanks!

I’m still looking for a different radio if anyone has suggestions on one they tried and liked.

@Nathan_Belk , You can’t go wrong with these: http://store.jdrones.com/RDF900_Telemetry_Modem_p/rdf900mdm1.htm

I have tested them on the NAVIO+ and they work great.

If you are interested in an antenna upgrade for these radio’s, I’m using these with the RDF900’s and they work great. FXP14.11.0100B ( http://www.taoglas.com/antennas/GSM-CDMA-Cellular/Internal_Flexible_PCB_antennas_-_FXP_Series/ )

I purchased a different pair of radios and it worked right off the bat. I need to replace the connector that it came with though, it looks similar but falls out of the Navio+ too easily.