[SOLVED] Navio2 - Getting MinimOSD to work

Curious if anybody has gotten the minimOSD to work with the Navio. Mine powers up fine, but then just sits there stating that it’s waiting for Mavlink heartbeats. I have APM running at startup with “sudo ArduCopter-hexa -A udp: -C /dev/ttyAMA0 > /home/pi/startup_log &”, which from what I understand should output telemetry to the uart. Any insight would be much appreciated!

Best regards


You’re absolutely right, Joseph. However, due to the fact that Navio 2 image is a little bit raw at the moment we have decided to leave the UART console to help inspect any Linux related problems. Once you disable the serial console in raspi-config, everything’s going to be fine.

Well, thanks for the suggestion. I disabled the serial console in raspi-config as suggested, power cycled, but still no go with the “waiting for Mavlink heartbeats” status. I guess better question would be, is there a better or more well suited OSD that is confirmed working with the Navio2? I don’t mind switching OSD boards, but having functional OSD for me is a must.

Best Regards

Don’t you also have to remove the console entry in cmdline.txt?

After starting over from scratch I was able to overcome the issue. Thanks to staroselskiy for pointing out that the serial console in raspi-config required disabling; it would have taken me a while to overcome that one on my own. In the end though I believe that the issue was due to user error/faulty wiring… Thanks none the less :smile: Now if only we could get motors 5 & 6 running…