SOLVED: Navio integration trouble

I’m having some trouble getting the Reach module to work with Navio+ on Arduplane.

Setup is as follows:
-Pi2 running the new emlid universal image
-Currently I’m running the lastest build from Ardupilot automated testing, which I believe should include ERB support.
-Reach is connected to UART on Navio
-Reach is configured according to the APM integration docs and is running ReachView 0.3.1.
-Arduplane is configured according to the APM integration docs.
-I’m running the command sudo ./Arduplane.elf -A udp: -B /dev/ttyAMA0 (I’ve also tried -E /dev/ttyAMA0)
-ReachView shows that I have a GPS fix.

Ground Station shows that I have no GPS fix, and 0 sat count. I’ve also tried switching to NMEA output on the reach and still no go. What am I missing?

Quick update:

I’m able to get it to work with ArduCopter, but not ArduPlane. Any ideas?

Second quick update: Parameter reset fixed it.

It looks like the culprit was the SERIAL4_PROTOCOL parameter. APM will default it to 6 if wasn’t previously set, but I had changed mine to 5, since 5 is typically GPS.