[SOLVED] Image 20150401 kernel panics


I got the image emlid-raspberrypi2-raspbian-rt-20150401.img from the download section and put it on a sd-card.

when starting the RPi2 i get a kernel panic:

List of partitions
b300                7782400 mmcblk0 driver: mmcblk
  b301                   57344 mmcblk0p1 0009bf4f-01
  b302               3138560 mmcblk0p2 0009bf4f-02
No filesystem could mount root, tried: ext4
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)
CPU: 3 PID: 1 Comm: swapper/0 Not tainted 3.18.9-rt5-v7+ #1

repairing the ext4 partitions seems to work with gparted.
when starting with the repaired partition still kernel panic:

EXT4-fs (mmcblk0p2): mountedfilesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:2.
devtmpfs: mounted
Freeing unused kernel memory: 392K (80766000- 807c8000)
hub 1-1:1.0: 5 ports detected
Starting init: /sbin/init exists but couldn’ execute it (error -80)
Starting init: /etc/init exists but couldn’ execute it (error -13)
Starting init: /bin/sh exists but couldn’ execute it (error -80)
Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation… etc.
CPU: 1 PID: 1 Comm: swapper/0 Not tainted 3.18.9-rt5-v7+ #1

what to do?
how can i make it boot?

thanks for any hints!

Well, there may be a lot of reasons for this:

  1. The download of the image went wrong.
  2. Something went wrong during the process of writing an SD card.
  3. SD card is not healthy.
  4. Raspberry Pi is not healthy.

yes, true.

i downloaded the image twice. both times same behaviour. is there a checksum for the image or an alternative location where i can download it from?

i used dd to copy the image. i use it regularly without any problems so far.

i used the SD cards with other images, it worked fine so far. but will try with a different one.

raspberry pi works fine with other images.

i used a different sd card, it works now!

thanks for pointing me the right direction :slight_smile: