[SOLVED] Connecting Navio+ with Mission Planner via ethernet

I have just completed my first quadcopter build and am now struggling to create a connection between Navio+ and Mission planner so that I may calibrate all the necessary sensors.

So far I have tried running the following command on the rpi: sudo ArduCopter-quad -A tcp: This brought about the following output: bind failed on port 5678 - cannot assign requested address. Next, i tried to run sudo ArduCopter-quad -C tcp: This time, the output on the command line is preceded with Init APM:Copter v3.3 (340970fc) and continues with what seems to be a calibration of the barometer and gyro before i used ctr+c to stop. Both of these outputs begin with: Raspberry Pi 2 with BCM2709!

My question is, using Ethernet cable for connection (the rpi is connected to my modem), how to connect Navio+ with Mission Planner? Am I correct in thinking that the address provided after ‘tcp:’ should be the IP address of my laptop?Then what should be the address after the last colon? What message should I expect to be displayed on the rpi so that I know that I may then proceed to establish the connection from my laptop?

My apology, I am a complete beginner. Thank you for any advice!

It turns out I was using the wrong IP address. If anyone else experiences the same problem, try running hostname -I to find out the IP address of your raspberry in its CLI. This is the address you specify when running sudo ArduCopter-quad -C tcp:(IP Address):14550:wait. Then open APM, set up a tcp connection, and use the same address.

1 Like