[SOLVED] Bash: emlid-raspberrypi2-raspbian-rt-2015-04-01: No such file or directory

Hello everyone,

I am trying to build a drone using a RPi B + and Navio+…all of this is very new but exciting !
I have downloaded the RT kernel for RPi2 on my Mac but I can’t seem to extract the image-tried everything, even “xz -d .img.xz” or unxz .img.xz, it keeps saying “No such file or directory”.

Any suggestion … ?



Hello and welcome, Maysun!

Could you please show us the commands you’d typed step by step?

It’s usually as easy as it gets:

  • Download the Raspbian distribution image from MEGA using the link provided in the docs.

  • Uncompress it

unxz raspbian.img.xz

  • Flash the SD Card

dd bs=1M if=rasbpian.img of=/dev/<sd_device>

After these have finished, you can stick your SD card into Raspberry Pi and see it boot.

Just a quick note.

If you’d used the link in out docs, you would’ve downloaded a complete distribution image rather than a Linux kernel. These are separate notions.

Just in case, we have a detailed explanation on writing the image to SD card here in the docs.

'Thank you !