[SOLVED] ArduCopter 3.3RC11 beta Current Ampere sensor wrong value

First thank you everybody for your awesome work with Navio and APM.
I am jumping into testing the last RC of ArduCopter-hexa 3.3RC11 beta.
The first thing I saw after switching to this beta release is that the current (amp) in the ground station is not accurate anymore, the real time current keep changing value from 1 amp to 4 amp, after measurement, the real consumed current is 0.4 amp.
This behavior is not showing in the release of the .deb package.

I was scared of a short circuit somewhere at the beginning lol :wink:


Could you please post the results after the following steps:

  • purge the parameters’ file (/var/APM/Arducopter.stg)
  • launch APM
  • select the power module in APM Planner
  • relaunch

I guess the parameters got corrupted during the update.

Worked like a charm, thx. :sunglasses:
Actually I am not doing any update, I am executing the “stable version” and just change my script to use the beta between 2 reboots by modifying the rc.local.
So I guess there is temp files that needs to be erased when switching.
Would it make sense to delete /var/APM after each reboot ?
I keep switching between the .deb version to the beta versions to understand changes and track bugs/behavior.

Nah, I don’t think that is a way go! The directory contains all the parameters which are to be persistent upon reboots, aren’t they?

The .deb version is pretty old. That’s why one might need to purge the parameters from the board. Some incompatible changes have been incorporated. So, I suggest removing *.stg when switching versions. Good luck!