[SOLVED] "AK8963: bad DEVICE ID" error during Ardupilot start

no, when I use gps I am outside home

For GPS to work there has to be a good sky view, it will work poorly in a building-dense area.
Also, mind that antenna has to be as far as possible from other electronics due to RF noise from it, even from the RPi itself.

Could you please run U-center with antenna placed outdoors and post a screenshot of satellite level bars?

This is a bit dated, but I’ve recently run into the same problem. Did you come up with a fix? Or is your board just faulty?


To test if compass is working, please do the following:

  1. Power off the Navio for a while (~30min).
  2. Power it on
  3. Run AccelGyroMag example as described here - http://docs.emlid.com/Navio-dev/mpu9250-imu/
    If compass values are not zero then it is okay.

If I run the test it is fine. If I power cycle it it is fine.

But I should not have to.

Say I’m onsite - about to fly - do I have to wait a half hour and hope that it works? What is a permanent fix?

The fix for this is already in the dev version (you can use it instead):

ArduCopter 3.3 is getting closer to the release, I hope that this rc is the last one.

Thank you for your excellent pointer. Running dev on the bench and it works quite well. Will try for some field trials later this week.

2 posts were split to a new topic: MPU9250: unexpected WHOAMI 0x0

This topic was automatically closed after 10 hours. New replies are no longer allowed.