MPU9250: unexpected WHOAMI 0x0

Is it possible that I may be having this same problem with a Navio@. I can’t anything to work I have tried reinstalling the firmware 3 times and I can’t get APM to launch. I keep getting the following error messge.

$ sudo ArduCopter-quad -C /dev/ttyAMA0
Raspberry Pi 2 with BCM2709!

Init APM:Copter V3.4-rc1 (dfa90d29)

Free RAM: 262144
FW Ver: 120

load_all took 12us
0 0 0 DataFlash_File: buffer size=16384
▒ Q}▒No INS backends available
MPU9250: unexpected WHOAMI 0x0

1 Like

I think the problem discussed in this thread is unrelated.

For the past couple of months the only two reason for the issue you’re observing are either not a properly screwed down to Raspberry Pi Navio 2 or a hardware fault (extremely unlikely). I suggest looking into the former.

Moved to another thread.

Please provide a close-up photo of your hardware setup.
Were you able to run APM previously? When did this problem appear?

I have never been able to connect to APM, i even went as far as buying a new navio2 board and I’ still stuck at the same point as before. i have tried everything possible and nothing. Can it be becuse of the RFD 900+ telemetry radios? i have them set at 115200 which should work with them but even with different radios set at 57600 i get the exact same error.

I had a second raspberry pi3 andd changeed it. it started working right away

Follow these steps to fix the Error 0x0 0x0:

  1. Go through the computer repair app on your Windows PC.
  2. Make sure your computer repair application is installed properly.
  3. For finding out the issue, click Scan Now.
  4. Once the device has been scanned, click the ‘Fix All’ option. This should fix the 0x0 0x0 issue.

I am going to bookmark this forum If you want more information about this you can contact us here.


1 Like