SmartNet SIM in RS2+

Has anyone had success with using a SmartNet-provided AT&T SIM card in the Emlid RS2+?

I am trying to rearrange my equipment to improve my workflow and moved my SmartNet SIM from my data collector to my RS2+ base so that I can take advantage of NTRIP Castor and increase my range. However, I can’t get the “Use mobile data” switch to turn on. I used the APN that SmartNet requires (m2m005125.attz) but still no luck. I don’t think I’m missing something on my end with the Emlid Flow settings, much less the Emlid Reach hardware that should be compatible with AT&T.

Hi Jared,

Do you have another SIM card to test with Reach RS2+? If it works fine, the reason is likely in this particular SIM card or its configuration.

You can send me the Full system report from the device, so I can check if there are any reports in the modem log. You can do that privately via PM or write us to

UPD: removed odd question and changed wording


I don’t have another SIM that I know would work in the RS2+. That’s kind of the problem. Very few cell networks will work with that modem for this purpose. Some work with the modem but not for an internet-only device. Others want more than I’m interested in paying for more data than I need so I haven’t bothered to give them a full trial.

Hi Jared,

I’ve received the report, thank you! I’ll check it and draw my conclusions in this thread.

Hi Jared,

According to the report, it looks like this SIM card either isn’t defined by receiver, or there’s PIN secure on it.

Please double-check that the SIM card fits tightly to the chip and the receiver determines it. Then, please share the screenshot from the Mobile data tab. If it requires authentication, you need to input credentials in this tab:

Network operator name is empty in the modem log, so I still assume it’s related to PIN secure somehow. So, you can also contact the provider to find out if there are any authentication requirements from their side.

Here is the screenshot.

The APN is the one SmartNet provided. They did not specify any username and password credentials. I tried reaching out to them for help but they’re notoriously non-responsive.

Hi Jared,

Thank you for the screenshot!

I still think it’s related to authentication, and the report confirms it.

Just in case, please check if credentials were given to you when you signed the contract with SmartNet, or probably they sent you them to the email.

I finally got word back from the network carrier. They think it has to do with the modem not being M2M compatible. Does that make any sense? I’m not sure what that means.

Hi Jared,

Reach RS2+ supports M2M SIM cards since 27 firmware release. But they may require an authentication that was shown in my previous post above.

Doesn’t the network carrier tell you credentials (username and password)?

As I said before, they do not require a username and password, just the APN.

Hi Jared,

Sorry for the silence here!

I got you. It sounds a bit weird because the report tells that the SIM card is secured by the PIN code.

Let me double-check your report and discuss your case within the team additionally. Once we have the result, I’ll post my conclusions here.

What is the workflow to connect to Smartnet. I see they do not have Emlid under their Rover Manufacture tab on the Connection and Configuration page

Do you:

  1. select Smartnet with RINEX as rover model
  2. other with Survey Grade as rover model

Hi Jared,

Thank you for your patience!

There’s one idea what can be the reason for inability to activate mobile data.

SmartNet is a virtual network carrier that uses AT&T physical network stations. In its turn, AT&T can provide SIM cards with a standalone data-only plan. And we’re aware that this plan may not be supported by Reach modem. Hence, AT&T has to mimic a hybrid data/voice plan instead of standalone data plan to make SIM cards operational with Reach.

I’d suggest you to recheck it with the network carrier. Most likely, SmartNet isn’t aware of this because they’re a virtual operator. If so, you can ask them to clarify this point from AT&T or try to contact them directly. Perhaps, the second way be of more help if SmartNet isn’t responsive.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.