Single Copter - I Put all parameters correctly, but work like a Coax Copter

Good morning , sirs !
I m follow all steps to make a single copter, i read the single copter & Coax Copter documentation.
I m lost , what i done ?

What exactly are you lost at? What do you want to achieve? What are the steps you’re performing? Without this essential information we’re in the dark and cannot really help you with the issue at hand. Please, give a little more information :slight_smile:

Hi George , appreciated your attention

show step by step what was configured.

I set all the configuration according to the documentation for emlid copters, step by step, https://docs.emlid.com/navio2/Navio-APM/building-from-sources/

I added this line: APM_Config.h: #define FRAME_CONFIG SINGLE_FRAME

in ardupilot documentation shows that the ESC Motor should be connected to the PWM 7, but on my plate are active, the outputs 5 and 6, like a copter coax.

When I move the pitch, it changes the rotation of the propeller.

I realize that the setting is just like a copter coax.

according to Ardupilot documentation configuration for a single copter should be this.

Connecting the Flight Controller to the SingleCopter:

Connect the APM PX4 or Pixhawk servant output channels 1-4 to the SingleCopters 4 control purposes the shown.
Connect the APM PX4 or Pixhawk servo output channel 7 to the ESC for the brushless motor que powers the main rotor single
The four ends are attached to four arms and it’s a bit like the Plus quad.
Looking down on the APM from above as in the attached diagram. “Servo1” would be attached to the APM’s output channel # 1, etc.

See this picture, shown as correctly , in mission planner

https://drive.google.com/open?id=0ByuA4rYKHf2AQkFNVmVpVHJWVjQ

It seems like an unnecessary step that should be deleted from ArduPilot’s docs. I’m not sure, though.

As of now, we build ArduCopter-single which is installed alongside other ArduPilot binaries using our Debian package. So there’s no need to build the code yourself.

I suggest trying to launch ArduCopter-single after sudo apt-get install apm-navio2

I’ve tried to do this, but still with the same problem , use this command:

sudo nohup ArduCopter -single -A udp : 192.168.1.2 : 14550e

I ran the command,
sudo apt- get install apm - navio2

already with the latest version

I sent a picture via a link, you may notice that shows

UPD14550 - quadrotor -1

Sorry I don’t understand what the problem is and this sentence is also not clear to me.

Excuse me, but you’ll need to guide us through a little bit in order to let us help you.

This is expected.

George,
Please see this link , http://ardupilot.org/copter/docs/singlecopter-and-coaxcopter.html

Ardupilot Documentation say :
“Connect the APM, PX4 or Pixhawk servo output channel 7 to the ESC for the brushless motor that powers the main single rotor”

In this text the author shows that the output PWM to the main single rotor would be the PWM 7, but , in my case, is activating PWM 5 and PWM 6 output ports , as the copter coax , is this normal?

Why the output PWM 7 , is not working, only the PWM 5 and PWM 6?

“UPD14550 - quadrotor -1”

Yes, it is expected, but is not working, it is working as described in the preceding lines .

I put the ESC connector in PWM 7 , and did not start the main rotor .

https://drive.google.com/open?id=0ByuA4rYKHf2AbGRWWlpJSXJfbkE

I put the ESC connector on the PWM 5 or 6 PWM , and both initialize the main rotor .

https://drive.google.com/open?id=0ByuA4rYKHf2ASE85M1RVS1dhZnM

How do I know if the system properly loaded the ArduCopter -single ? is there any log or information that can guide me ?