SIM Card- M2M

We have two RS2+.
We are trying to activate the internet connection using M2M SIM card.
RS2+ recognize the SIM card but when we tried to activate the mobile data (APN was selected) it is turing off after few second.
Mobile data is turn on with a regular SIM card but it is not working with M2M SIM card.
Do we have to use a regular SIM for RS2+ (doesn’t support M2M SIM) or we are missing something.

Hi there,

Same problem here but with the RS3 and also the RS2+ . I have a data sim cards from KPN. When I want to connect with mobile data, then the mobile data function cannot be activated.

However, i did found a workaround by accident. When you let the receiver connect automatically at startup with the mobile hotspot of your phone, then it wil activate the mobile data. You can then connect to the receiver in hotspot mode and work with mobile data function on like it should.

Funny thing is that when I insert a sim card from T-Mobile, it connects instantly… strange. By the way I have the most recent firmware installed on both receivers and also tried using the latest beta firmware

Thank you for your quick respose. I will try the soluiton and let you update if it works or not for me.

Hi @decodemap,

Some SIM cards require enabling the Data roaming option. So, let’s start with enabling it under the Mobile data settings and check if the connection works that way. If it doesn’t help, let’s also double-check that the username and password are entered correctly.

If you still face the issue, please generate a full system report and send it to We’ll have a closer look at what’s going on.

@lammert.degraaf, do you also have an M2M SIM card? What kind of SIM is the one from T-Mobile which is working fine?