Several problems with Navio2 copter

I spent a not so successful morning out on the field trying to get my copter to fly.
With the latest emlid raspbian image, I used apt-get update/upgrade to get the latest compass fixes. No joy, no second compass present.
Downloaded the latest apm.deb with wget and now it has a second compass.
2nd compass set to external and roll 180°, all goes well.
Heading out to the field, powering up the copter, GNSS fix with 15sats, great!
Wait a moment, the compass is off 180° now, what´s that?
Setting the 2nd compass to pitch 180°, recalibrating, everything fine with the compass again.
AHRS_Orientation is set to 4 (yaw 180°) for my copter and as far as I know, the external compass must be set relative to the AHRS_Orientation, but in this case I had to add the AHRS_Orientation to the compass orientation myself. I hope it is clear what I am trying to say.
Another reboot, compass is working and… no GNSS fix… :frowning:
Tinkering with the GNSS settings, I was able to get a more or less stable fix with 12 sats max, but the copter icon was moving around the map all the time. My Mini Skyhunter with a pixfalcon and a M8N GNSS has a fix with up to 19 sats in the same spot.
First flight, stabilize mode worked, but was undertuned and sluggish. Tried althold mode and it was constantly rising and falling. I changed throttle hover to 0.46 because the copter was hovering with a little less than half throttle. (This method worked with my overpowered pixhawk copter).
Althold was suddenly really agressive, but not able to hold an altitude.
I thought I had done something wrong, had a look at the arducopter wiki and I am pretty sure, they describe the procedure for throttle hover setting the wrong way around. Have a look if you like:

Next I wanted to tune the PIDs to get it to fly more stable, but all the boxes were greyed out in mission planner (except for a few I never really needed before) and even the slider for roll/pitch sensitivity was not present.
I just had enough then and went home.

That is strange. Navio 2 has to compasses onboard. And we need to set the second one as external only for now. I know it’s confusing, but there’s no way around it just yet. It’ll be fixed in the next release but for now please pay attention!

The onboard logs would help us!

I will upload them as soon as I am back home.

Here is the dataflash log from yesterdays flight, would the parameter file be helping, too?

5.BIN.nav (2.0 MB)

Sebastian, thanks for the report.
Seems like you’re always “lucky” to experience most of the issues :sweat:

We will check the logs.
And we’ll add more info about the compass in the docs.
Regarding the GNSS receiver not having fix - if that happens try to change the antenna and see if it has immediate effect. Maybe the antenna cable is starting to tear.

I had issues with the PID values being grayed out with ArduCopter 3.4-dev. I was able to set them thru the full parameters list under ATC.

The antenna has always been in the same place and the cable has never been moved or stressed, except from the airflow.

Thank you, I did not think of this way back then.