Setup for connecting m+ rtk with pixahawk4

Hello emlid community,
I tried to connect pixahawk4 with reach rtk m+ module using the instructions in the following url:
https://docs.emlid.com/reach/ardupilot-integration/

The document illustrates the process for the setup for pixahawk3 with with rtk. Since i am using pixahawk4, i connected the module to uart and i2c port instead of the serial port using uart connection. When powering the pixahawk, no power is reaching the m+. To resolve this issue, i followed the instruction for the pins configuration for the rtk and pixahawk using the following websites

https://docs.px4.io/v1.9.0/en/flight_controller/pixhawk.html
https://docs.emlid.com/reachm-plus/specs/

I realized that the connectors are flipped out (i used the wires from pixahawk), so i manually attached the pins to the correct configuration and i was able to power the module with pixahawk.
I also was able to configure the reach and base using reach view, i chose the position output to be TCP and the correction input to serial (UART).
https://d.top4top.io/p_1477pukj00.jpg
After that i followed the same instruction to connect the mission planner after tunning the rtk parameter, however it still shows that there is no available gps as shows in the next picture. My questions are, was someone able to launch pixahawk4 with m+ module using mission planner? If yes, what is the exact setup? How to configure rtk with the mission planner?

https://e.top4top.io/p_1477brdv21.jpg
This is the report from the app indicating the status for the rovèr and the base respectiveley:

Simple system report
app version: 2.20.8-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.0.189
is_added: true
is_connected: true
is_visible: false
mac_address: 6C:21:A2:E7:18:91
security: wpa-psk
ssid: dlink-7698
uuid: c6fd5e97-f960-4684-9931-b0025ae7f46d
base mode:
base coordinates:
accumulation: '2'
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- '0'
- '0'
- '0'
format: llh
mode: single-and-hold
output:
enabled: false
format: rtcm3
path: tcpsvr://:9000#rtcm3
type: tcpsvr
rtcm3 messages:
'1002':
enabled: true
frequency: '1'
'1006':
enabled: true
frequency: '0.1'
'1010':
enabled: true
frequency: '1'
'1097':
enabled: false
frequency: '1'
'1107':
enabled: false
frequency: '1'
'1117':
enabled: false
frequency: '1'
'1127':
enabled: false
frequency: '1'
bluetooth:
discoverable: false
enabled: false
pin: '***'
camera:
duty cycle: 20
enable: false
period: 2
polarity: true
correction input:
input2:
enabled: true
format: rtcm3
path: 192.168.0.194:9000
send position to base: 'off'
type: tcpcli
input3:
enabled: false
format: rtcm3
path: :9028
type: tcpsvr
logging:
base:
format: RTCM3
started: true
version: null
correction:
format: RTCM3
started: true
version: null
interval: 24
overwrite: true
raw:
format: UBX
started: true
version: null
solution:
format: LLH
started: true
version: null
lora:
air rate: 2.6000000000000001
frequency: 868000
output power: 20
position output:
output1:
enabled: true
format: erb
path: ttyMFD2:38400:8:n:1:off
type: serial
output2:
enabled: true
format: llh
path: :9001
type: tcpsvr
output3:
enabled: true
format: llh
path: :2014
type: tcpsvr
output4:
enabled: true
format: llh_ext
path: :2015
type: tcpsvr
rtk settings:
elevation mask angle: '15'
glonass ar mode: 'off'
gps ar mode: fix-and-hold
max horizontal acceleration: '1'
max vertical acceleration: '1'
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzss: false
sbas: false
snr mask: '35'
update rate: '5'

Base:

Simple system report
app version: 2.20.8-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.0.194
is_added: true
is_connected: true
is_visible: false
mac_address: 6C:21:A2:3A:12:BA
security: wpa-psk
ssid: dlink-7698
uuid: d8566a4b-da12-446c-b1cc-9e0172bb0930
base mode:
base coordinates:
accumulation: '2'
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- '0'
- '0'
- '0'
format: llh
mode: single-and-hold
output:
enabled: true
format: rtcm3
path: tcpsvr://:9000#rtcm3
type: tcpsvr
rtcm3 messages:
'1002':
enabled: true
frequency: '1'
'1006':
enabled: true
frequency: '0.1'
'1010':
enabled: true
frequency: '1'
'1097':
enabled: true
frequency: '1'
'1107':
enabled: true
frequency: '1'
'1117':
enabled: false
frequency: '1'
'1127':
enabled: false
frequency: '1'
gps:
enabled: false
frequency: '1'
qzss:
enabled: false
frequency: '1'
bluetooth:
discoverable: false
enabled: false
pin: '***'
correction input:
input2:
enabled: false
format: rtcm3
path: ttyMFD2:38400:8:n:1:off
send position to base: 'off'
type: serial
input3:
enabled: false
format: rtcm3
path: :9028
type: tcpsvr
logging:
base:
format: RTCM3
started: true
version: null
correction:
format: RTCM3
started: true
version: null
interval: 24
overwrite: true
raw:
format: UBX
started: true
version: null
solution:
format: LLH
started: true
version: null
lora:
air rate: '18.23'
frequency: 868000
output power: '20'
position output:
output1:
enabled: false
format: nmea
path: :9000
type: tcpsvr
output2:
enabled: false
format: llh
path: :9001
type: tcpsvr
output3:
enabled: true
format: llh
path: :2014
type: tcpsvr
output4:
enabled: true
format: llh_ext
path: :2015
type: tcpsvr
rtk settings:
elevation mask angle: '25'
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: '1'
max vertical acceleration: '1'
positioning mode: static
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzs: true
qzss: false
sbas: false
snr mask: '30'
update rate: '5'

Your help is really apperciated,
Regards,
Abdulla

Hi Abdulla,

Thanks for the detailed report.

What flight stack do you use?

Hello Dmitriy,
We are using pixhawk4 arudopilot 3.6.12.
Regards,

Hi Abdulla,

May I ask you to try outputting the position from Reach M+ in NMEA instead of ERB?