Setting up Navio2 but can not calibrate RC

Hello All,

I just recieved my Navio2 this week and have slowly been setting it up.
I get as far as the RC Calibration in Ardupilot but can not get the Navio2 to see anything.
Radio Calibration Shows nothing when I wiggle the sticks on the RC.

I also tried sudo cat /sys/kernel/rcio/rcin/ch2 while changing the Transmiter stick positions and nothing.

I have tested with a different reciever which does not have PPM out (FS-IA10), this goes through a convertor, still no joy.
My Reciever (FS-IA6b) shows 5.08 volts so it is getting the power it needs.

Tried updating to Apm 3.4 Dev too.

My Transmitter is a updated Flysky i10, with PPM enabled.

I have no way of checking PPM output from the reciever my other flight computer is a dodgy APM2.5, I do not have access to an oscilloscope, is there another way I can check?

If anyone has any ideas,


Have you bound your receiver and transmitter combination?

Yes, they are bound. I get the voltage telemetery from the Reciever apearing on the Transmitter so must be OK. I also tried connecting the reciver to a Hobbyking K2 with PPM disabled and thats working.

Thanks Lowres.

Yes, Yes, its working, working well. I have been trying every combination for the last 2 days, and after posting here tried one more time and its working great, AI10 reciever > PPM converter > Navio2.

No idea what the magic combination was, just pure hope and a little praying I suspect. Maybe the APM 3.4 Dev version helped because that is one of the last things I did.

Take it easy,