Servo is not working when connected to Navio board

After making sure the servo rail is supplied power by a voltage regulator my servo’s still not working. It makes some moves when powering on the system but no reaction to the controller.
If I connect that servo directly to the X8R transmitter (same channel) it does work.
What am I doing wrong?
Thanks.

Could you please provide a photo of how everything is connected?
What models the regulator and the servo are?

Are you running APM?
If so, you have to tell APM what to do with the output your servo is connected to. Open the full parameter list and scroll down till you get to all the RC_x parameters. Search for the output number
(was it RC_7 in your previous thread?) and set RC_7_function to “passthrough”. Do not forget to write the new settings. You might have to restart APM for the new setting to take effect. Now your servo should work.

1 Like

I cannot set it to a string, it accepts numbers only.

I have the following config:

New photo by István Janó

Also, I’ve just realised after connecting the 4 motors with ESCs, they don’t work either.

I’ve got this quad:
https://www.unmannedtechshop.co.uk/dys-d800-x4-professional-multi-rotor-package-for-aerial-photography-and-heavy-lift-pnf/

update: They do work. :slight_smile:

I just could not remember the value for passthrough as I wrote my answer. There is a list with all values behind each RC_X_FUNCTION entry in Missionplanners full parameter list. Value for passthrough is “1”.

You need to arm your copter with the yaw stick to the right and throttle down. Hold it for a few seconds until the Navios LED starts to flash.
You can also arm through your GCS software.
Prearm checks might prevent arming, if APM detects anything not ready for flight.

I set RC7_function to 1.
When I’m trying to write it to the ROM I get the following error:

There are locally changed parameters. Please transmit them first () or update them with the onboard values () before storing onboard from RAM to ROM.

I also tried clicking the “set” button first, I get the following: TIMEOUT: MISSING 0 read, 0 write.

Which GCS software do you use? I never saw a message like this before.

APM Planner 2.0 (Mac)

I do not use APM planner anymore, so I do not know how recent versions work.

What do you use?

Missionplanner on Windows 10.

I see, thanks.
I thought MissionPlanner is outdated and APM Planner is the new MissionPlanner. But I’ll check MP too.

Missionplanner is Windows only. There are ways to run it on Linux natively, but for me it crashed quite often. I do not know if it runs on Mac. In a virtual machine perhaps.

I’ve got a Windows desktop too so that I’ll use it.

Okay, I managed to set it to 1 via the Mission Planner. It resulted a weird issue: The motors now randomly spinning for a fraction of a seconds… :confused:

Sorry. Forget that about the GCS software discussion. You need to use output 9-14 to avoid this issue.

Alright, I’ll move it to 9. How can I manage to control it with the RC? Actually this is the landing gear servo… I’ve got an FrSky X8R receiver … can it handle more then 8ch?

update After a quick search, it can handle 16ch through ppm. That case I do what you’ve said with the RC9.
Thanks

update2 Same weird issue with the motors … :S