Emlid

Community Forum

Servo Gimbal On Emlid Egde


(Antonios Antzoulatos) #1

Trying to configure a 2 axis servo gimbal on my edge with PWM 10 and 11 as Tilt and Roll and 12 as Cam Trigger.
I have done a million times on Pixhawk (any kind) and works straight out of the box but here i have a problem.
As soon as i set Type to servo on Servo10 and Servo 11 and reboot, my gimbal becomes centered and i can see servos having power to stay center.
No matter if i activate or deactivate the Stabilize check box, nothing moves no matter how much i move the Octa around (Servo 9 is Landing Gear and i have only 10-12 free).
Would it matter that UAV is not armed? Because it seems that as soon as it boots on Servo Type Gimbal, the servos center. but after that no movement.
@tatiana.andreeva any help on this?


(Antonios Antzoulatos) #3

In addition to my previous post i have the following finding.
These are two standard NON digital servo by sanwa. if i manipulate the PWM limits or angle limits on QGC i can see the servos moving, but if i have stabilize checked and simply try to move the UAV around, servos simply stay in middle position.
As about my Cam trigger, i tested again and again activating from QGC and triggers fine.
Why would edge not even try to move the servos when stabilize is checked?


(Tatiana Andreeva) #4

Hi @tonyantzoulatos,

What’s the model of gimbal you use? Could you please share your hardware setup photos?


(Marc Lebret) #5

Hello,

I had a try with servo on my Edge. I swapped tilt gimbal control line to a Hitec HS82MG servo. There is a 5 volt bec on the servo rail.

Servo is responding to the tilt command of RC Tx, when Stabilize case is checked, Servo move if Edge is tilted up and down.

Maybe something to check:

Servo 10 and 11 fonction have to be set as 7 (mount-tilt) and 8 (mount roll).

Marc


(Antonios Antzoulatos) #7

Hello and my apologies for not comming sooner to reply to you all.
a) @tatiana.andreeva, this gimbal is a servo gimbal that uses two very expensive servos
b) @mlebret Thank you for your responce.
I had found the solution only to say that its strange based on my day to day experience with these builds.
If an actual radio channel was assigned to the FC for the appropriate servo function (tilt or roll) then everything worked. If there was NO input channel from radio, then the FC could not stabilize the gimbal.
This makes it look really strange since on my last 6 months Pixhawk 2.1 builds (more than 7 copters) this was not the case, i have seen this only on the edge.
For now its solved but this means that you need more than 8ch for what i wanted to do, which in many cases on the 2.1 i can even do with 7 channels from the radio, since the FC controls these on its own.