Servo example not working on Navio 2 with 4.14 image

I just installed the official 4.14 image and try to run the Navio2 C++ servo example. However, the program exits with
Can't init channel 0
But when I run an older image (4.4) the servo program works fine and I can hear the sound it’s producing. I’ve tried this on another Navio 2 board and the result is the same.

I also found the following errors with dmesg:

[ 10.383585] rcio spi1.0: rcio_status: Could not read board type
[ 10.384587] rcio spi1.0: rcio_status: Could not read git hash
[ 10.385746] rcio spi1.0: rcio_pwm: Advanced frequency configuration is not supported on this firmware

All I did with the image is running sudo apt-get update && sudo apt-get upgrade, sudo raspi-config --expand-rootfs, and sudo apt-get install pigpio which is required to compile the example.

Any help would be appreciated.

Hi @chenjiyang1991,

May I ask you to run sudo emlidtool ardupilot and check if all tests are passed. Please share the screenshot of emlidtool here.

Then run the ardupilot with emlidtool, not with systemctl.

1 Like

Using sudo emlidtool ardupilot shows the RCIO firmware is outdated. After updates the example works. Here are the screen shots before the udpates. Thank you for the help!

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.